IBM Support

Administration Center installation fails during fix pack installation.

Troubleshooting


Problem

The installation of the Tivoli Storage Manager Administration Center fails with the following message: The Tivoli Integrated Portal fix pack installation failed.

Symptom

The following messages are displayed


Cause

Package Extraction is incomplete

Diagnosing The Problem

This type of failure can happen for various reasons but a typical reason is that a file is missing from the Package Extraction location. Review the log.txt file for a error message similar to the following:

Install, com.ibm.ws.install.ni.ismp.actions.InstallNIFPackage, err, C:\Downloads\TSM\TSM V 6.3.3 Admin Center\cdimage.fixpack\COI\PackageSteps\WebSphereUPDI\FILES\7.0.0.17-WS-UPDI-WinIA32\UpdateInstaller\updi.primary.pak\repository\nif.componentmap.primary\properties\version\nif\componentmaps\componentmap.primary.xml (The system cannot find the file specified.)
Install, com.ibm.ws.install.ni.ismp.actions.InstallNIFPackage, err, The file properties/version/nif/componentmaps/componentmap.primary.xml could not be replaced.
Install, com.ibm.ws.install.ni.ismp.actions.InstallNIFPackage, err, com.ibm.ws.install.ni.framework.fileactions.NIFFileActionIOException: The file properties/version/nif/componentmaps/componentmap.primary.xml could not be replaced.

Resolving The Problem

In this case, a file was missing because the package extraction was incomplete. Verify that that missing file referenced in the context message is missing from the package extraction location and follow the steps below.

  1. Extract the Package again but to a smaller path as the file extraction can have issues if the extraction path is too big. In this case, the original extraction path was "C:\Downloads\TSM\TSM V 6.3.3 Admin Center\" and changed to C:\AdminCTR
  2. Check to make sure that the missing file is listed in the new extraction location.
  3. Un-install the Tivoli Storage Manager Administration Center by running the uninstaller from the following location: C:\IBM\tivoli\tsmac\_unist\uninstaller
  4. Run the Administration Center Installation again.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21627098