TEC EventServer fail to initialize with error FRWTE00017E

Technote (troubleshooting)


Problem(Abstract)

The Tivoli Enterprise Console Server is initializing...
Error::FRWTE0017E Thu Feb 21 09:55:26 EST 2013 (17): system problem:

Symptom

The wtrace shows the following.

.
loc-ec 1475 M-ho 2-1455 0 e=12
Time run: [Wed 20-Feb 21:11:16]
.
Object ID: 1321829881.2.26#Tec::Server#
Method: is_dataserver_running
Principal: root@IBM-YTOSTD02-Q00 (-2/-2)
Helper pid 708644 Path:
/usr/local/Tivoli/bin/aix4-r1/TME/TEC/tec_db_calls
Trans Id:
{

1321829881:2,1321829881:2,354:210
}
#4
.
Results: (encoded):
.
"Exception:UserException:SysAdminException::ExException:SysAdminE
xception::ExSystem:SysAdminException::ExStdlib"
{
.
"Exception:UserException:SysAdminException::ExException:
.
SysAdminException::ExSystem:SysAdminException::ExStdlib"
"TasExCat" 18 "%5$t
{
%c


}
(%3$d): `%8$s' failed with code `%9$d': `%7$s'"
1361412676
.
{
0
}
"" "iom_create" 38
}
.
loc-ec 1495 M-hdoq Extern 0 e=12
Time run: [Wed 20-Feb 21:11:18]
.
Object ID: 1321829881.2.26#Tec::Server#
Method: wait_for_server
Principal: root@IBM-YTOSTD02-Q00 (0/-2)

Helper pid 872670 Path:
/usr/local/Tivoli/bin/aix4-r1/TME/TEC/tec_server
.
Results: (encoded):
.
"Exception:UserException:SysAdminException::ExException:SysAdminE
xception::ExSystem"
{
.
"Exception:UserException:SysAdminException::ExException:
SysAdminException::ExSystem" "TasExCat" 17 "%5$t
{
%c
}
.
Wstartesvr fails with the following message.

The Tivoli Enterprise Console Server is initializing...
Error::FRWTE0017E Thu Feb 21 09:55:26 EST 2013 (17): system problem:
iom_create failed With Code 38
`'

Cause

Security scan scripts had changed the permissions on the 'TIVOLI_COM_DIR'

Diagnosing the problem

Since we suspected a possible permissions issue, we looked at the permissions for the various Tivoli directories. We found out that '/tmp/.tivoli', the TIVOLI_COM_DIR had permissions set to '750'. After changing it back to '777', we were able to start the EventServer without any problem.

Resolving the problem

Setting the proper permissions on the 'TIVOLI_COM_DIR' directory resolved the issue

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Tivoli Enterprise Console

Software version:

3.9

Operating system(s):

UNIX

Reference #:

1627035

Modified date:

2013-03-01

Translate my page

Machine Translation

Content navigation