Troubleshooting
Problem
User launches Controller client. User receives error message.
Symptom
Error
An Error occurred while trying to access the server.
[Details] [OK]
Error Details
Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: startIndex
[OK]
Cause
There are several possible causes for this error message.
- TIP: See separate IBM Technote #1669496 for more examples.
This Technote specifically relates to the scenario where the cause is that the Controller application server does not contain the required IIS virtual directories (in order to process requests from the client).
- Specifically, it is caused by 'ibmcognos\controllerserver' being missing (or invalid).
Resolving The Problem
Ensure that the Controller application server contains the correct IIS virtual directories/applications in its website, such as:
- ibmcognos
- ibmcognos\cgi-bin
- ibmcognos\controller
- ibmcognos\controllerbin
- ibmcognos\controllerhelp
- ibmcognos\controllerserver
TIP: The ones highlighted in bold are the most relevant directories for this issue.
Related Information
[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
15 June 2018
UID
swg21626956