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"Index was out of range ... Parameter name: startIndex" when launching Controller client


Technote (troubleshooting)


Problem(Abstract)

User launches Controller client. User receives error message.

Symptom

Error

An Error occurred while trying to access the server.
[Details] [OK]

Error Details
Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: startIndex
[OK]

Cause

Controller database needs to be optimised so that the indexes/statistics are updated.

Resolving the problem

Perform a database optimisation inside Controller, and make sure that the indexes/statistics are updated.

Steps:

  1. Launch Controller, and logon as an administrator (e.g. ADM)
  2. Click "Maintain - User - Single Mode"
  3. Click "Maintain - Database - Optimize"
  4. Select/tick/enable all possible options (especially "Rebuild Indexes" if using SQL, and "Analyse Schema" if using Oracle)
  5. Click "Run".

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Document information

Cognos Controller

Controller


Software version:
10.1.1


Operating system(s):
Windows


Reference #:
1626956


Modified date:
2013-03-08

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