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"Access to the path 'V:\folder\xxxxx.FTD' is denied" when trying to save files on local drive via Citrix published application

Troubleshooting


Problem

Customer is deploying Controller via Citrix. User tries to save a file on their local hard drive. User receives error message. For example, user clicks "Transfer - Export Data", and then chooses parameters, browses to their local hard drive (i.e. the laptop/desktop PC's hard drive) and then clicks the blue "run" button. User receives error message.

Symptom

The error message will vary slightly depending on:

  • What function the end user is trying to use
  • What options they have chosen
  • The version of Citrix client/server that they are using
  • How the Citrix client is configured.

Below are some examples:


(1) Information
V:\ is not a valid directory.
[OK]

(2) Error
The physical file represented by the item could not be created.
Type Xceed.FileSystem.DiskFile
FullName: V:\folder\xxxxx.FZD
[OK]

(3) Error
Access to the path 'V:\folder\xxxxx.FTD' is denied.
[OK]

Cause

There are several possible causes for similar error messages.

  • For more examples, see separate IBM Technote #1626626.

This Technote specifically relates to the scenario where the cause is that the Citrix client is configured to deny write access to the end user's local hard drive.
  • For example, error (1) was produced when the setting "Access level" was set to "No Access":
  • Errors (2) and (3) were produced when the setting "Access level" was set to "Read Access".

Environment

Controller client delivered to end user via Citrix.

Resolving The Problem

Reconfigure the Citrix client so that it allows read and write access to the end user's local hard drive.

Steps:

The steps will vary greatly depending on which version of the Citrix client is being used, and how the client is being deployed.

  • For more information, see third-party (non-IBM) links at the bottom of this Technote.

For example, in one real-life scenario (where the program was being launched by directly double-clicking on an ICA file) the solution was to open the "Citrix Program Neighborhood Connection Center" systray icon, then click on the "File Security" button and change the setting of "Access level" to "Full Access":


  • TIP: To ensure that the change is permanent, click "Never ask me again".

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21626474