Installation Manager does not restart after you update to a later version

Technote (troubleshooting)


Problem(Abstract)

You update IBM Installation Manager from version 1.6.1 or earlier to version 1.6.2. After the update completes, Installation Manager does not restart automatically.  The restart of Installation Manager fails with the error:
"An error has occurred. See the log file
/opt/IBM/InstallationManager/eclipse/configuration/log_file_name.log."

Symptom

This issue occurs when the following steps are taken:

1. Install Installation Manager version 1.6.1 or earlier.
2. Start the installed instance of Installation Manager.
3. Go to File > Preferences.

    a. Go to Repositories.
    b. Add a repository for Installation Manager version 1.6.2.
    c. Go to Updates.
    d. Select the Search for Installation Manager updates option.
    e. Click OK.
4. Click Install.
5. You are prompted to update Installation Manager to a later version. Click Yes.
6. After the update completes, you are prompted to restart Installation Manager.  Click OK.

Installation Manager updates to the later version but does not restart.  In the log file, you see messages similar to the following entries:

!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.aix.ppc_1.1.100.vYYYYMMDD-1822 [610] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.aix.ppc 2 0 YYYY-MM-DD 13:56:26.647
!MESSAGE Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=aix) (osgi.arch=ppc))

Cause

Installation Manager version 1.6.2 uses the GTK window system. Installation Manager versions 1.6.1 and earlier use the Motif window system. Because of differences in the window systems, a restart does not occur after Installation Manager version 1.6.2 is installed.

Resolving the problem

To work around this issue, manually start Installation Manager after the update completes.

For information about installing required GTK system libraries, see Required gtk libraries for Installation Manager on AIX and Required gtk libraries for Installation Manager on HP-UX Itanium.

Related information

Required gtk libraries for Installation Manager on HP-U
Required gtk libraries for Installation Manager on AIX

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

IBM Installation Manager
Install

Software version:

1.0, 1.0.0.1, 1.0.0.2, 1.0.0.3, 1.0.0.4, 1.0.0.5, 1.1, 1.1.0.1, 1.1.0.2, 1.1.1, 1.1.2, 1.2, 1.2.1, 1.3, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.4.1, 1.4, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.5, 1.5.0.1, 1.5.1, 1.5.2, 1.5.3, 1.6, 1.6.1, 1.6.2

Operating system(s):

AIX, HP-UX

Reference #:

1626283

Modified date:

2013-04-25

Translate my page

Machine Translation

Content navigation