IBM Support

Error installing Jazz for Service Management when Installation Manager is already installed in a non-ASCII location

Troubleshooting


Problem

When you install Jazz for Service Management by using an existing Installation Manager installation in a non-ASCII location, the installation fails.

Cause

When Installation Manager has been installed into a non-default location that contains non-ASCII characters in the path, the Jazz for Service Management installation fails. It fails because the path to the Installation Manager JRE, which is passed to and used by the integration services CLIs for their configuration, is not recognized as a valid path.

Resolving The Problem

Jazz for Service Management ships with Installation Manager Version 1.6.1 and you can reinstall Installation Manager to a different location that does not contain non-ASCII characters.

To reinstall Installation Manager:

  1. Open a command window and browse to the JazzSM_Image_Home/im.platform_name directory.
    • JazzSM_Image_Home is the path to the common directory that stores the extracted Jazz for Service Management installation media.
    • platform_name is the name of the supported platform, for example, aix, linux.s390, linux.x86_64, or windows.x86.
  2. Run the following command to reinstall Installation Manager:
    Operating system

    Administrator

    Non-administrator

    UNIX ./install -reinstallIM -installationDirectory New_IIM_Installation_Home ./userinst -reinstallIM -installationDirectory New_IIM_Installation_Home
    Windows -install.exe -reinstallIM -installationDirectory New_IIM_Installation_Home -userinst.exe -reinstallIM -installationDirectory New_IIM_Installation_Home

    New_IIM_Installation_Home is the new installation path for Installation Manager that does not contain non-ASCII characters.

  3. Restart Installation Manager and start the installation of Jazz for Service Management again.

Connect, learn, and share with the Jazz for Service Management Community

Jazz for Service Management has an active community that can provide you with additional resources. Browse and contribute to the forums and the blog. Review the wiki on topics such as best practices. You can also learn more about upcoming releases, provide feedback, or suggest enhancements.
See the Jazz for Service Management community in Service Management Connect.

Related Information

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Document Information

Modified date:
25 October 2021

UID

swg21626235