SUA v2.0 - Import function failed with "the 'PRIMARY' filegroup is full" message.

Technote (FAQ)


Question

SUA v2.0 - Import function failed with "the 'PRIMARY' filegroup is full" message.

Cause

After successfully uploaded the IBMSoftwareCatalog_canonical_2.0_form_20121215.xml (December 2012) software catalog, the import function failed with the follow error:

ERROR: Sequel::DatabaseError: NativeException: com.microsoft.sqlserver.jdbc.SQLServerException: Could not allocate space for object 'dbo.datasource_fixlets_scd'.'datasource_fixlets_scd_id_index' in database 'tem_analytics' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.


Answer

This error is most likely to occur if the MS SQL Server 2005 Express is being used for "tem_analytics" database. Due the database size limitation for MS SQL Server 2005 Express is 4gig, the default initial database size created for "tem_analytics" is already set to 4gig limits with unrestricted growth.

When the import function attempts to insert more data from the latest software catalog into "tem_analytics" database more then it can hold beyond 4gig, it will fails with the above message as it could not expand the database size due to database size limitation.

To resolve the issue, it is highly recommended to use a full version of MS SQL Server. Alternatively, migrate it to MS SQL 2008 Server R2 SP2 Express with 10gig database size limits. Do not upgrade the MS SQL Server 2005 Express to MS SQL 2008 Server R2 SP2 Express as it will run into a number of upgrade problems. It is better off to uninstall MS SQL Server 2005 Express and its instance completely before installing MS SQL Server 2008 R2 SP2 Express as a new installation. Then attach the databases back afterward. Ensure there is a full backup of any databases before performing any operation. Consult MS SQL Administrator for assistance.

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Document information


More support for:

Tivoli Endpoint Manager

Software version:

8.2

Operating system(s):

Windows

Reference #:

1626073

Modified date:

2013-03-08

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