IBM Support

Ldap authentication fails with ICM8023

Troubleshooting


Problem

Content Manager Enterprise Edition v8.4.3 (CM) ldap authentication fails with ICM8023 after upgrading Windows system to support 64-bit library.

Symptom

Ldap authentication fails with ICM8023.

The LDAP library loading failed.


Explanation
The IBM® Content Manager LDAP authentication component failed to find
and load the LDAP library to make a function call.
User response
Verify that the ITDS client was correctly installed on the library

Cause

The IBM Tivoli Directory Server (ITDS) SDK V6.1 64-bit client is installed per the requirement when planning to use a 64-bit CM library, however during the installation, the Windows PATH environmental variable was not updated to reflect the path of the ITDS SDK.

Environment

Windows V7, CM V8.4.3 64-bit library

Diagnosing The Problem

Confirm that the CM library trace reports ICM8023 for the failed ldap authentication.

Resolving The Problem

Manually update the Windows PATH environmental variable to include the directory path of the ITDS SDK 64-bit client. For example, add


D:\IBM\LDAP\V6.1\lib64

Restart the Windows operating system to ensure that the updated value is accepted.

Related Information

[{"Product":{"code":"SSAHQR","label":"IBM Z System Automation"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Library Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4.3","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

Modified date:
17 June 2018

UID

swg21625983