System time synchronization causes unusual behavior between IBM Business Process Manager (BPM) servers and databases

Technote (troubleshooting)


Problem(Abstract)

If the time between your IBM Business Process Manager servers and databases are not in sync, you see unusual behavior. One example of this behavior is duplicated tasks.

Cause

The Event Manager is responsible for executing tasks and instances. It moves tokens along the business process definition (BPD) and service engines. All time stamps for records in the database are based off the database server time. The Business Process Manager servers use their local time to schedule the execution process and grab new tasks from the general pool. If the time between the Business Process Manager installation and the database server is not in sync, there can be accidental overlap between when event managers grab new tasks. This scenario might cause the accidental duplication of tasks

Resolving the problem

Verify that all nodes in your Business Process Manager installation and all nodes in the database (if the database is clustered) are all on the same time clock. A best practice is to have all servers use the same NTP server.

Cross reference information
Segment Product Component Platform Version Edition
Business Integration IBM Business Process Manager Advanced General AIX, Linux, Linux zSeries, Solaris, Windows, z/OS 8.0.1, 8.0, 7.5.1, 7.5

Product Alias/Synonym

BPM

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Document information


More support for:

IBM Business Process Manager Standard
General

Software version:

7.5, 7.5.1, 8.0, 8.0.1

Operating system(s):

AIX, Linux, Linux zSeries, Solaris, Windows

Reference #:

1625955

Modified date:

2013-02-19

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