“HTTP 404 Not Found - The webpage cannot be found” error when using Application Export functionality with the Integration Framework

Technote (troubleshooting)


Problem(Abstract)

Getting the following message: "The webpage cannot be found HTTP 404" on application Users and trying to use "Application Export" button using a previous created Object Structure. The .dat file is then automatically saved to the application server folder ".../IBM/maximo/Interfaces/appexport/flatfiles".

Symptom

This is the step-by-step list for reproducing the issue:

S01) Log in Maximo 7.5.0.3 as Maxadmin;
S02) Go to Integration -> Object Structures;
S03) Click on New Object Structure button at the top for creating a new record;
S04) For "Object Structure" enter IBM_OBJSTR and provide any description value for the Description field at the right of this field;
S05) For "Consumed By" choose "Integration" from the pick list;
S06) Check the check box field "Support Flat Structure";
S07) On the "Search Objects for IBM_OBJSTR" section below click on
"New Row";
S08) For "Object Name" choose MAXUSER from the pick list;
S09) Click on "New Row" button;
S10) For "Object Name" choose MAXUSERSTATUS from the pick list;
S11) For "Parent Object" choose MAXUSER from the selection;
S12) For "Relationship" choose MAXUSERSTATUS from the pick list;
S13) Click on "New Row" button;
S14) For "Object Name" choose MAXUSRDBAUTHINFO from the pick list;
S15) For "Parent Object" choose MAXUSER from the selection;
S16) For "Relationship" choose DMMAXUSRDBAUTH from the pick list;
S17) Click on "New Row" button;
S18) For "Object Name" choose GROUPUSER from the pick list;
S19) For "Parent Object" choose MAXUSER from the selection;
S20) For "Relationship" choose GROUPUSER from the pick list;
S21) Click on "New Row" button ;
S22) For "Object Name" choose GROUPUSER from the pick list;
S23) For "Parent Object" choose MAXUSER from the selection;
S24) For "Relationship" choose GRPREASSIGNAUTH from the pick list;
S25) Click on "Save Object Structure" button ;
S26) Go to Selection Action menu on the top bar and choose "Add/Modify Application Export Support";
S27) On the "Add/Modify Application Export Support" window box click on the "New Row" button;
S28) For "Application" choose "User" from pick list;
S29) For "Maximum count" delete any content in there (set to null allowing any number or records);
S30) For "Default File Type" check "Flat File";
S31) Click on the "OK" button;
S32) Go to Selection Action menu on the top bar and choose "Add/Modify Application Import Support";
S33) On the "Add/Modify Application Import Support" window box click on
the "New Row" button;
S34) For "Application" choose "User" from pick list;
S35) For "Maximum count" delete any content in there (set to null allowing any number or records);
S36) For "Default File Type" check "Flat File";
S37) Click on the "OK" button;
S38) Go to Selection Action menu on the top bar and choose "Add/Modify Alias";
S39) On the "Add/Modify Alias" window box, for "Source Objects for IBM_OBJSTR" section, select the "MAXUSERSTATUS" record;
S40) On the "Alias Setting for Object MAXUSERSTATUS" click on the ALIASNAME field for STATUS and change it from "STATUS" to "IBMDUP_STATUS" (this will resolve this field-name duplication);
S41) On the "Add/Modify Alias" window box, for "Source Objects for IBM_OBJSTR" section, select the "MAXUSRDBAUTHINFO" record;
S42) On the "Alias Setting for Object MAXUSRDBAUTHINFO" click on the ALIASNAME field for LOGINID and change it from "LOGINID" to "IBMDUP_LOGINID" (this will resolve this field-name duplication);
S41) On the "Add/Modify Alias" window box, for "Source Objects for IBM_OBJSTR" section, select the "GROUPUSER" record;
S42) On the "Alias Setting for Object GROUPUSER" click on the ALIASNAME field for GROUPNAME and change it from "GROUPNAME" to "IBMDUP_GROUPNAME" (this will resolve this field-name duplication);
S43) On the "Add/Modify Alias" window box, for "Source Objects for IBM_OBJSTR" section, select the "GRPREASSIGNAUTH" record;
S44) On the "Alias Setting for Object GRPREASSIGNAUTH" click on the ALIASNAME field for GROUPNAME and change it from "GROUPNAME" to "IBMDUP_GROUPNAME" (this will resolve this field-name duplication);
S45) Click on the OK button - Make sure for all Objects have no Duplicate? setting checked. If you have it you will need to change the alias names as well;
S46) Click on the "Save Object Structure" button at the top;
S47) Go to Security -> Security Groups;
S48) Load MAXADMIN security group;
S49) Click on the "Applications" tab;
S50) Click on Filter and load "Users" application information;
S51) For the second section below, make sure "Application Export" and "Application Import" have "Grant Access?" check box field checked;
S52) Click on the Save Group button at the top;
S53) Open your Internet Browser options and on the "Security" tab;
S54) For the "Local intranet" zone click on "Custom Level" button at the bottom of the screen;
S55) Make sure the following settings are set under "Downloads":

- Automatic prompting for file downloads: Enable;
- File download: Enable;
- Font download: Enable;

S56) Go to Security -> Users;
S57) Select some users for a test;
S58) Click on "Application Export" button on the toolbar;
S59) For the "Application Export" windows box, click on "Object Structure" pick list icon;
S60) Choose the Object Structure we have created before "IBM_OBJSTR";
S61) Expand "Export Configuration" section and confirm that "Flat File" is checked as you have established as default for this application;
S62) Click on OK;
S63) At this point customer will receive a page with the error "HTTP 404 Not Found - The webpage cannot be found".

We would expect the following to happen instead of the error above to happen:

S63) You will then receive a "File Download - Security Warning" with the following question : "Do you want to open or save this file?" ;
S64) Click on Save;
S65) Choose a folder on you local drive;
S66) Save the file;
S67) Open the file and confirm if the content you expected to find is in there.


Cause

The file cannot be found. You see the following similar error in the SytemOut file when reproducing the issue (sample):

[2/18/13 11:07:23:399 EDT] 00000035 servlet com.ibm.ws.webcontainer.servlet.ServletWrapper init SRVE0242I:
[MAXIMO_UI] [/maximo] [intdownload]: Initialization successful.
[2/18/13 11:07:23:430 EDT] 00000035 SystemOut O Context is /maximo/intdownload
[2/18/13 11:07:23:430 EDT] 00000035 servlet E
com.ibm.ws.webcontainer.servlet.ServletWrapper service SRVE0068E:
Uncaught exception created in one of the service methods of the servlet
intdownload in application MAXIMO_UI. Exception created :
java.io.FileNotFoundException:
appexport\flatfiles\IBM_OBJSTR1234567890123456789.dat (The system
cannot find the path specified.)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:126)
at
psdi.webclient.servlet.IntegrationFileDownloadServlet.processRequest(Int
egrationFileDownloadServlet.java:148)
at
psdi.webclient.servlet.IntegrationFileDownloadServlet.doGet(IntegrationF
ileDownloadServlet.java:231)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:718)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:831)
at
com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.ja
va:1663)
(...)

Environment

Maximo 7.5.0.3

Diagnosing the problem

D1) You will be receiving the error when trying to use the functionality: "HTTP 404 Not Found - The webpage cannot be found";

D2) You will see the following error in the SystemOut log file: Uncaught exception created in one of the service methods of the servlet intdownload in application MAXIMO_UI. Exception created : java.io.FileNotFoundException: appexport\flatfiles\IBM_OBJSTR1234567890123456789.dat (The system cannot find the path specified.)

D3) You will see that the file IBM_OBJSTR1234567890123456789.dat will be available on WebSphere server at the folder .../IBM/maximo/Interfaces/appexport/flatfiles.

D4) When checking on the mxe.int.globaldir system property (System Configuration -> Platform Configuration -> System Properties) you see it will have a “Current value" but not a "Global Value" populated (null). You will not be able to change the “Global Value” field once it is grayed-out (read-only).

Resolving the problem

Global Value field should be updated from Current Value. Once it has not been updated and it has null value system will not be able to find the file on the specified folder as it reads on Current Value field. You need to force this update following these steps:

R1) Log in Maximo as Maxadmin user;

R2) Go to System Configuration -> Platform Configuration -> System Properties;

R3) Click on filter and enter mxe.int.globaldir and hit ENTER to load this record;

R4) Expand the record and see as per your previous information that Global Value is empty but Current Value is not;

R5) Check mark the box at front of the record "mxe.int.globaldir" and go to Select Action on the top bar and select the 1st option "Live Refresh";

R6) The Live Refresh window box will show up including the mxe.int.globaldir on the list. Click OK for confirming it;

R7) Log out and then stop Maximo application server.

R8) Redeploy EAR file by clearing up the old log files and Application Server cache folder. Please, refer to the technote 1462246 - Redeploy the Maximo EAR File(s).

R9) Restart Application Server machine;

R10) Try to use functionality again.

Related information

Redeploy the Maximo EAR File(s)
Error 404 when exporting data from the list screen

Cross reference information
Segment Product Component Platform Version Edition
Systems and Asset Management IBM SmartCloud Control Desk

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Document information


More support for:

IBM Maximo Asset Management
ML Export Import

Software version:

7.5

Operating system(s):

Platform Independent

Reference #:

1625880

Modified date:

2014-01-14

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