Java WebStart TEP client does not start on Windows 7

Technote (troubleshooting)


Problem(Abstract)

After upgrading to Windows 7, TEP client (Java WebStart method) no longer starts.

Symptom

The execution fails with the following errors :

com.sun.deploy.net.FailedDownloadException: Unable to load resource:

http://host.xxx.dev.yyy:15200/commons-discovery-0.2.jar.jnlp


at com.sun.deploy.net.DownloadEngine.actionDownload(Unknown Source)
at com.sun.deploy.net.DownloadEngine.getCacheEntry(Unknown Source)
at com.sun.deploy.net.DownloadEngine.getCacheEntry(Unknown Source)
..
..
..
Wrapped Exception

java.net.ConnectException: Connection refused: connect
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(Unknown Source)
at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)

Cause

Possible explanations for this failure are :

1) IHS not running on TEPS system
2) Firewall preventing communication with port 15200
3) Corrupted or invalid local files on workstation machine where TEP client is launched

Nothing explicitly related with Windows 7, unless specific firewall rules have been applied with the new
operating system

Resolving the problem

1) Check if port 15200 is in LISTENING on the TEPS server.If not, likely the IHS is not running and you need to investigate about failures on TEPS side, considering that IHS should be started and stopped automatically with TEPS service.

2) If port 15200 is available and in LISTENING on TEPS, verify if any firewall (locally to the workstation that is trying to launch TEP or the network boundary firewall) is preventing communication with that specific port. You may need to change firewall rules to allow access on port 15200.

If the first two options are fine, communication works normally so it is possible that the problem is with the application or JNLP file locally stored on the Windows workstation.

3) On the workstation where TEP client runs, from Windows Control Panel, open the Java Control Panel and clear the Java cache.Then download TEP application again using the following URL from a web browser:

http://TEPS_host_name:1920///cnp/kdh/lib/tep.jnlp

In this way you will get rid of any inconsistency of the TEP client application previously downloaded.


Product Alias/Synonym

IBM Tivoli Monitoring V6.2.3 Tivoli Enterprise Portal Client

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Document information


More support for:

Tivoli Components
ITM Tivoli Enterprise Portal V6

Software version:

6.2.3.1

Operating system(s):

Windows

Reference #:

1625840

Modified date:

2013-05-15

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