Troubleshooting
Problem
Informix upgrade process failed with error "Open transaction detected when changing the log version".
Symptom
During an Informix version upgrade, you swapped the Informix binaries with newer version and trying to start up the server. Server startup fails with following messages printed in the message log:
Open transaction detected when changing log versions.
Cannot Rollforward from Checkpoint.
Cause
Informix server was not shut down gracefully prior to start upgrade process that left an open transaction in the logical log. Server could not commence the conversion process until the open transaction rolled back.
Resolving The Problem
Revert the Informix environment to use the older version of binary files. Run 'oninit -s' to start the database server in quiescent mode. Next, shut down the server gracefully by running 'onmode -uky' command. Then switch the binaries back to newer version again and start the server.
Was this topic helpful?
Document Information
Modified date:
03 June 2021
UID
swg21625458