Skip to main content

Error 500 when logging into Maximo


Technote (troubleshooting)


Problem(Abstract)

When a user tries to log in to Maximo, it appears to validate the credentials then displays an Error 500 on page.

Cause

This can be caused when you try to log into Maximo with a user that does not have a Person Account. When creating a user through the front end Maximo requires that a person record be created as well. However during data migration or upgrades it is possible there could user accounts migrated without a person account if the field has been modified to not be required.

Diagnosing the problem

If you receive the error 500 on log in check your WebSphere systemout.log for the following NullPointerException.

00000051 servlet E com.ibm.ws.webcontainer.servlet.ServletWrapper service SRVE0068E: Uncaught exception created in one of the service methods of the servlet webclient in application MXServer. Exception created : java.lang.NullPointerException
at psdi.webclient.system.session.WebClientSession.getLoginEvent(WebClientSession.java:2427)
at psdi.webclient.system.session.WebClientSession.createEvent(WebClientSession.java:5998)
at psdi.webclient.system.session.WebClientSession.handleNonClientQueueRequest(WebClientSession.java:6035)
at psdi.webclient.system.session.WebClientSession.handleRequest(WebClientSession.java:830)
at psdi.webclient.system.session.AsyncRequestManager.handleRequest(AsyncRequestManager.java:284)
at psdi.webclient.system.session.AsyncRequestManager.manageRequest(AsyncRequestManager.java:227)
at psdi.webclient.system.controller.RequestManager.manageRequest(RequestManager.java:247)

Resolving the problem

To resolve this problem log in with a user that has a person account and privileges to access the People application and create a person record that matches the user record.


The following query can be run to determine which users do not have associated records in the person table.

select * from MAXUSER where personid not in (select personid from person)

Cross reference information
Segment Product Component Platform Version Edition
Systems and Asset Management IBM SmartCloud Control Desk 7.5

Rate this page:

(0 users)Average rating

Copyright and trademark information

IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.

Rate this page:


(0 users)Average rating

Add comments

Document information

IBM Maximo Asset Management

Maximo Login


Software version:
7.5


Operating system(s):
Platform Independent


Reference #:
1625390


Modified date:
2013-02-14

Translate my page

Content navigation