Technote (troubleshooting)
Problem(Abstract)
After installing the WebGUI Fix Pack multiple times it finally is successful but the listed APARs do not appear to be fixed
Symptom
APARs listed in the Fix Pack readme are not fixed but the listIU.sh output reports that the Fix Pack is installed.
Cause
Temporary installer files cause the Fix Pack to report success even is the install failed.
Resolving the problem
After a WebGUI Fix Pack install attempt is made and the installer fails you must run the uninstall script if it exists and/or remove the temp installer files. Then check the installation log for the failure correct the failure and re-install the Fix Pack.
Scenario One: Installation fails and the uninstall.sh Does exist under the IBM/tivoli/netcool/omnibus_webgui/_uninst/<Fix Pack version>/ directory.
1) Run the uninstall.sh
a) Update the uninstall_response.txt under the IBM/tivoli/netcool/omnibus_webgui/_uninst/<Fix Pack version>/ with the tipadmin password
b) uninstall[.bat|.sh] <full_path_JRE> <full_path_response_file>
2) Move the <Fix Pack version> directory and install log
a) mv IBM/tivoli/netcool/omnibus_webgui/_uninst/<Fix Pack version> IBM/tivoli/netcool/omnibus_webgui/_uninst/<Fix Pack version>_old
b) mv ~/IBM_Tivoli_Netcool_OMNIbus_Web_GUI_<FP Version>_Install-00.log ~/IBM_Tivoli_Netcool_OMNIbus_Web_GUI_<FP Version>_Install-00.log_old
3) Remove the install files under /temp
a) rm -r -f /tmp/acsiTemp_<install username>
4) Review the installer log and fix the failure.
5) Run the FP installer
Scenario Two: Installation fails and the uninstall.sh Does NOT exist under the IBM/tivoli/netcool/omnibus_webgui/_uninst/<Fix Pack version>/ directory.
1) Move the <Fix Pack version> directory and install log
a) mv IBM/tivoli/netcool/omnibus_webgui/_uninst/<Fix Pack version> IBM/tivoli/netcool/omnibus_webgui/_uninst/<Fix Pack version>_old
b) mv ~/IBM_Tivoli_Netcool_OMNIbus_Web_GUI_<FP Version>_Install-00.log ~/IBM_Tivoli_Netcool_OMNIbus_Web_GUI_<FP Version>_Install-00.log_old
2) Remove the install files under /temp
a) rm -r -f /tmp/acsiTemp_<install username>
3) Review the installer log and fix the failure.
4) Run the FP installer
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