IBM Support

Define Path command fails with ANR8300E with KEY=02, ASC=04, ASCQ=8D.

Troubleshooting


Problem

Unable to define a path to an IBM library using Tivoli Storage Manager. The command fails with the ANR8300E error.

Symptom

The DEFINE PATH command fails with the following error :

ANR8300E I/O error on library TS3310LTO4 (OP=80506C06, CC=-1, KEY=02, ASC=04, ASCQ=8D

Cause

Library or Library Partition is offline

Diagnosing The Problem

The IBM Tape Diagnostic Tool software needs to be downloaded to verify the functionality of the library before it can be defined to the Tivoli Storage Manager server. Once downloaded and the tool is extracted, run the following itdt batch commands :

./itdt -f /dev/IBMchanger0 inquiry
./itdt -f /dev/IBMchanger0 inquiry 80

The tool can also be started in interactive mode by running "./itdt". From the menu, select :

[1] Open a Device ...enter /dev/IBMchanger0
[55] Initialize Element Status

If any of the above commands return an error, it indicates an issue with the driver and/or hardware.

NOTE: IBM Tape Diagnostic Tool is for IBM Libraries only

Resolving The Problem

In this particular case, the combination of the KEY, ASC and ASC values translate to :

KEY=02 --> Not ready.

ASC=04, ASCQ=8D --> Library or Library Partition offline.

Make sure that the library or library partition is not offline. In this case, it was offline.

Refer to the Tivoli Storage Manager descriptions of I/O codes for more information about the KEY, ASC and ASCQ values.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All Supported Versions","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21625278