Technote (troubleshooting)
Problem(Abstract)
After successfully applying an update to IBM Rational Integration Tester (RIT) of IBM Rational Test Workbench (RTW), you cannot start the program.
Symptom
Installation Manager successfully applies the update, but you experience one of the following symptoms.
- When you start RIT, all you see is the splash screen appear and then disappear.
- When you start RIT, you see an error window "GH Tester" with the following message.
An error has occurred. See the log file <log file name>
The log file contains multiple errors. They report that bundles cannot be resolved.
- You cannot start Library Manager and see no error message.
Cause
During the update process the Java JAR cache becomes corrupted. This prevents the programs from finding their required library files. Therefore they cannot start.
Resolving the problem
Start on the command line using the -clean option.
This issue is documented in the Rational Test Workbench Fix Pack Release Notes below:
Rational Test Workbench Fix Pack 2 (8.0.1.2) for 8.0.1
- Open a command window.
- Navigate to the RIT installation folder.
Windows
cd C:\Program Files\IBM\Rational Integration Tester
Other operating systems
cd /opt/IBM/RIT
- Run RIT.
Windows
GHTester.exe -clean
Other operating systems
./GHTester -clean
- Run Library Manager for RIT or Agent.
Windows
LibConfig.exe -clean
Other operating systems
./LibConfig -clean
NOTE
The programs will take longer to start with the -clean option, because you then rebuild the caches before normal program operation.
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