IBM Support

RMAN backup of Oracle database may fail with ANS0326E (RC41)

Troubleshooting


Problem

RMAN backup may fail unexpectedly with message ANS0326E (RC41), indicating that the maximum number of mount points exceeded.

Symptom

RMAN may terminate a channel with error
ORA-19511: Error received from media manager layer, error text:
ANS0326E (RC41) This node has exceeded its maximum number of mount points.
RMAN-12018: channel t4 disabled, job failed on it will be run on another channel.

This might be logged on processing of the second or of a following backup piece by this RMAN channel, although setting of MAXNUMMP is the same as the number of RMAN channels.

Cause

The Tivoli Storage Manager Server and the client (in this case the Data Protection for Oracle) work asynchronously after ending a session.
In case of a Library Server / Library Client configuration it might take longer to release a mountpoint. So, a new session, requesting a new mountpoint, exceeds the maximum number of mountpoints, set for this node.

Diagnosing The Problem

The 'Maximum Mount Points Allowed (MAXNUMMP)' value can be found on the Node definition on TSM Server via the 'query node {nodename} f=d' command.

Resolving The Problem

Increase / up to double the setting for MAXNUMMP for the Oracle node, in case the above issue is faced. Use this command:

>UPDate NOde {nodename} MAXNUMMP={value}


This will have no long-term side-effects as the Tivoli Data Protection option (in the above case the number of allocated RMAN channel) will throttle the resource use to the expected level.

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Document Information

Modified date:
17 June 2018

UID

swg21624975