IBM Support

Jobs return with return code 128 and no work was done

Troubleshooting


Problem

Windows systems have been found to return 128 for jobs while the return code does not apply to the work that the job should be doing. The rc=128 is being returned by the Windows operating system.

Symptom

TWSMERGE.log entry:


BATCHMAN:* AWSBHT061E Batchman has received a mailbox record indicating that the following job has stopped unexpectedly

TWS joblog records a return code of 128.

Cause

Windows explains return code 128 with the following:

ERROR_WAIT_NO_CHILDREN
128 (0x80)
There are no child processes to wait for.

For TWS this means that JOBMON process was not able to create the
job process.

Resolving The Problem

This issue can be resolved using the methods defined below:

1. Desktop heap shortage:

http://support.microsoft.com/kb/126962


2. MS security update 958690 (MS09-006):

http://support.microsoft.com/default.aspx?scid=kb;EN-US;974509


3. System reboot. This will likely serve as a temporary workaround.

The JOBMON process is not able to create the job process due to a system resource limitation or due to a security issue.

Related Information

[{"Product":{"code":"SSGSPN","label":"IBM Workload Scheduler"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4;8.5;8.5.1;8.6","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

Maestro;TWS;TWA

Document Information

Modified date:
17 June 2018

UID

swg21624571