Technote (troubleshooting)
Problem(Abstract)
The URL to the IBM Rational Directory Server (RDS) and the password credentials for the Rational Directory server may get changed on the Rational Directory Server itself and the change needs to be updated in the Rational Change application as well to allow for administration operations.
Symptom
Rational Change admin cannot connect to Rational Directory Server after password change on RDS.
Cause
The password or URL was changed in RDS and needs to be changed in the Rational Change
application.
Diagnosing the problem
Has the password, URL or username been changed on the Rational Directory Server?
Resolving the problem
Edit the Rational Directory Server (RDS) URL in the rds_config.xml file.
- In the rds_config.xml file edit the <url> line:
<rds-config>
<url>ldap://host:port/</url>
- Save the file if that is all that is needed.
- If the RDS Admin username and password needs to be changed as well:
- In the rds_config.xml edit the username and password lines.
<user-id>tdsadmin</user-id>
<password>xxxxxxxxxxxxxxxxxx/xxxxxxxxxxx==</password>
- Put in the new user name and replace the <password> line with
<password-unencrypted>my_new_password</password-unencrypted>
The user name is changed, but the original <password> is replaced with <password-unencrypted>, whose content is a clear-text password. When the server reloads, the password is encrypted.
- In the rds_config.xml edit the username and password lines.
Rate this page:
Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.