Technote (troubleshooting)
Problem
Removing a name from "Show Calendars" causes your Notes client to crash. When unchecking the box under "Show Calendars", the Notes client may crash if the name field is blank.
Symptom
In certain circumstances a user's name under "Show Calendars" may appear blank. If the user tries to uncheck the box (to hide those calendar entries from the view), then Notes will crash.
Cause
This has been identified as a product defect under APAR LO68085 / SPR GMAA8SEFYH.
Diagnosing the problem
The NSD file will generate a Fatal Thread that matches the following:
############################################################
### FATAL THREAD 1/14 [ NLNOTES: 0ebc: 05a0]
### FP=0x00122d70, PC=0x6213c084, SP=0x00122d5c
### stkbase=00130000, total stksize=241664, used stksize=53924
### EAX=0x00122db4, EBX=0x00000001, ECX=0x00000000, EDX=0x00123510
### ESI=0x00123510, EDI=0x6200b7f0, CS=0x0000001b, SS=0x00000023
### DS=0x00000023, ES=0x00000023, FS=0x0000003b, GS=0x00000000 Flags=0x00010216
Exception code: c0000005 (ACCESS_VIOLATION)
############################################################
@[ 1] 0x6213c084 nxmlproc.DOM_Node::getNodeValue+36 (122da8,6200b7f0,123510,62014310)
@[ 2] 0x6200c19c nxmlproc.XmlNodeImpl::getNodeValue+60 (123510,0,0,12355c)
@[ 3] 0x6200b808 nxmlproc.XmlNode::getNodeValue+24 (123510,63dfcd40,7,0)
@[ 4] 0x63457057 nnotesws.CExecuteActionsRequest::ExecuteParameterizedAction+567 (8945018,0,124d84,2)
@[ 5] 0x63459149 nnotesws.CExecuteActionsRequest::Execute+1337 (128418,12858c,175f468,8945018)
@[ 6] 0x61f92403 nxpm.CXmlRequestProcessor::ProcessRequestExt+819 (3b21484,175f4e8,0,0)
@[ 7] 0x61f91550 nxpm.CXmlRequestProcessor::ProcessRequest+32 (3b21484,f9,128e90,128ea0)
@[ 8] 0x635950bb nnotesws.ProcessWksMsgExt@32+11819 (90,19080000,0,80022a26,0,0,0,0)
@[ 9] 0x630345a3 nnotesws.CheckWksMQ@4+435 (0)
@[10] 0x63026b80 nnotesws.CDeskSubprogram::SubMessageProc+6448 (1eda218)
@[11] 0x63024d26 nnotesws.MainWndProc@16+7782 (105ec,570,0,0)
[12] 0x76efc4e7 USER32.gapfnScSendMessage+463 (63022ec0,105ec,570,0)
[13] 0x76efc5e7 USER32.gapfnScSendMessage+719 (0,63022ec0,105ec,570)
[14] 0x76efcc19 USER32.gapfnScSendMessage+2305 (63022ec0,0,12977c,630b8efb)
[15] 0x76efcc70 USER32.DispatchMessageW+15 (129758,1,305c6,63020000)
@[16] 0x630b8efb nnotesws.NEMMainLoop@4+811 (4013a0)
@[17] 0x00401a41 NLNOTES.WinMain@16+1697 (630f67c0,0,7d262d,0)
@[18] 0x00402721 NLNOTES.WinMainCRTStartup+389 (7ffdf000,12ffd4,778f377b,7ffdf000)
[19] 0x775ded6c kernel32.BaseThreadInitThunk+18 (7ffdf000,77870429,0,0)
[20] 0x778f377b ntdll.RtlInitializeExceptionChain+239 (40259c,7ffdf000,0,0)
[21] 0x778f374e ntdll.RtlInitializeExceptionChain+194 (40259c,7ffdf000,0,905a4d)
Resolving the problem
A fix is being investigated for a future release of Notes. As a workaround, copying one database to a new one resolved the issue. This can be done with the Admin Tools utility (option #4):
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