Technote (troubleshooting)
Problem(Abstract)
The Warehouse Proxy Agent crashes soon after startup. The <InstallDirectory>/logs directory has numerous javacore*.txt files showing failures with the khdxprtj" process and OutOfMemoryError messages.
Cause
One possibility is that initialization processing requires a larger maximum heap memory size to be configured.
Diagnosing the problem
Review the <InstallDirectory>/logs directory contents, and confirm if there are javacore*.txt files. If so, confirm whether they reference the Warehouse Proxy Agent (khdxprtj process). If so, confirm whether an OutOfMemoryError is occurring.
Resolving the problem
1. Edit the <InstallDirectory>/config/hd.ini file, where <InstallDirectory> is the directory where ITM is installed (for example, /opt/IBM/ITM/config/hd.ini). Change the following line:
KHD_JAVA_ARGS=
To this:
KHD_JAVA_ARGS=-Xms256m -Xmx1024m
This sets the minimum heap size to 256 MB, and the maximum heap size to 1024 MB.
2. Restart the Warehouse Proxy Agent (itmcmd agent start hd).
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