Modify Server Resources request is failing with a CTJZH8317I error

Technote (troubleshooting)


Problem(Abstract)

A Modify Server Resources request to increase the disk on a P-Series server fails with:
'CTJZH8317I - Blue Cloud Processing has finished for project
/cloud/rest/projects/xxxx/ with failures returning status unrecoverable.'

Symptom

The Work Log of the Service Request in the SimpleSRM UI shows:

CTJZH837I - Blue Cloud Processing has finished for project
/cloud/rest/projects/xxxx/ with failures returning status unrecoverable.

CTJZH8318W - Service request yyyyy was closed or only partially resolved due to errors during processing.


Cause

The DCM export shows the value of 'how-many' as '1' for the disk in the associated VST that is being used by the Modify Server Resources request. This value needs to be modified to '0'.

Diagnosing the problem

You will messages similar to the below in the SystemOut and trace logs:

[12/21/12 11:21:38:468 EST] 0000004d SystemOut O 21 Dec 2012
11:21:38:468 [DEBUG] class com.ibm.ism.pmrdp.bc.api.HTTPExit
processResponseData EXIT

[12/21/12 11:21:38:468 EST] 0000004d SystemOut O 21 Dec 2012
11:21:38:468 [DEBUG] class com.ibm.ism.pmrdp.bc.api.BlueCloudAPIImpl
getLocationState NOTE json result was =
{"uri":"https:\/\/localhost:9443\/cloud\/rest\/projects\/xxxx\/servers\/
305195\/modification\/","type":"servermodification","state":"unrecoverab
le","link":[]}

[12/21/12 11:21:38:468 EST] 0000004d SystemOut O 21 Dec 2012
11:21:38:468 [INFO] class com.ibm.ism.pmrdp.bc.api.BlueCloudAPIImpl
getLocationState INFO state of location
'/cloud/rest/projects/xxxx/servers/305195/modification/' is
unrecoverable

[12/21/12 11:21:38:468 EST] 0000004d SystemOut O 21 Dec 2012
11:21:38:468 [DEBUG] class com.ibm.ism.pmrdp.bc.api.BlueCloudAPIImpl
getLocationState EXIT

[12/21/12 11:21:38:469 EST] 0000004d SystemOut O 21 Dec 2012
11:21:38:469 [DEBUG] class
com.ibm.ism.pmrdp.bc.action.ActionCustomClassCheckForBlueCloudTerminatio
n applyCustomAction NOTE status:unrecoverable

[12/21/12 11:21:38:469 EST] 0000004d SystemOut O 21 Dec 2012
11:21:38:469 [DEBUG] class
com.ibm.ism.pmzhb.common.actions.WorkorderHelper
addMessagesToServiceRequestWorkLog ENTRY

[12/21/12 11:21:38:469 EST] 0000004d SystemOut O 21 Dec 2012
11:21:38:469 [DEBUG] class
com.ibm.ism.pmzhb.common.actions.WorkorderHelper
addMessagesToServiceRequestWorkLog ENTRY

[12/21/12 11:21:38:488 EST] 0000004d SystemOut O 21 Dec 2012
11:21:38:488 [DEBUG] class
com.ibm.ism.pmzhb.common.actions.WorkorderHelper
addMessagesToServiceRequestWorkLog NOTE MsgId:CTJZH8317I

[12/21/12 11:21:38:489 EST] 0000004d SystemOut O 21 Dec 2012
11:21:38:489 [DEBUG] class
com.ibm.ism.pmzhb.common.actions.WorkorderHelper
addMessagesToServiceRequestWorkLog NOTE MsgText:CTJZH8317I - BlueCloud
processing has finished for project /cloud/rest/projects/xxxx/ with
failures returning status unrecoverable.

Resolving the problem

In order to modify the value of 'how-many' from '1' to '0' for the disk in the associated VST that is being used by the Modify Server resources request, please execute the following steps:

Login to management server and execute the following as ctginst1 user.
1. db2 connect to <database_name> (e.g: maxdb71)
2. db2 set schema maximo
3. db2 "update resource_requirement set how_many=0 where
server_template_id='<server_template_id>' and resource_type_id=2"

Note: You find the server_template_id iby filtering on the VST name in
the Object column of the Data Model Object Finder in the Start Center
of the Maximo Admini UI.

Please also subsequently make sure that there is no left over of the previous failed
requests in the TSAM topology node, DCM and VST for the disk value of
the particular server. If so, please fix this value to the original
correct value and then proceed with a new request for modifying server
resources.

Follow the steps below for fixing these values:

1. Fix the Virtual Server Template (VST)
- In the Maximo Admin UI Start Center enter the id of the VST in the Data
Model Object Finder and select it
- Fix the disk value accordingly

2. Fix the Resource Allocation of the server in DCM
- In the Maximo Admin UI Start Center enter the name of the server in the Data
Model Object Finder and select it
- Next to the field "Total disk size (GB)" click on the double arrow to
navigate to the Detail Menu
- Next to the field "Resources Allocated From" click on the double
arrow and select 'Resource Allocation'
- Fix the disk value

3. Fix the topology node
- Find out the name of the project that the server belongs to
- Go to related Service Deployment Instance (SDI) in the Maximo Admin UI
- Select the Service Topology tab
- Navigate to Service Topology Node of the server and fix the disk
value (PMRDPCLCVS_STORAGE_SIZE).

Cross reference information
Segment Product Component Platform Version Edition
Systems and Asset Management IBM Service Delivery Manager AIX 7.2.2, 7.2.1

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Document information


More support for:

Tivoli Service Automation Manager

Software version:

7.2.1, 7.2.2, 7.2.2.2

Operating system(s):

AIX

Reference #:

1624166

Modified date:

2013-01-31

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