Troubleshooting
Problem
Setting up a second instance of IBM Atlas eDiscovery Process Management(Atlas) for fail over purposes causes an application lock error.
Symptom
The application is down, login screen is inaccessible and a lock error appears in the logs.
Cause
When two instances of Atlas are running at the same time, the ApplicationLock mechanism will prevent both instances from accessing the same database.
Environment
Occurs in all environments.
Diagnosing The Problem
There will be an application lock error in the logs indicating another instance has tried to access the same database:
Error]-[Unable to lock application [PolicyAtlas] due to
[com.secretseal.policyatlas.service.exceptions.ApplicationLockException:
Lock for application [PolicyAtlas] is unavailable at this time.].]:
com.secretseal.policyatlas.service.exceptions.ApplicationLockException:
Unable to lock application [PolicyAtlas] due to
[com.secretseal.policyatlas.service.exceptions.ApplicationLockException:
Lock for application [PolicyAtlas] is unavailable at this time.].
Resolving The Problem
There is no fail-over functionality available in Atlas at this time. In order to achieve this, one server must be physically stopped, before you start the other.
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Document Information
Modified date:
17 June 2018
UID
swg21623932