IBM Support

Two Atlas instances running simultaneously causes application lock issue

Troubleshooting


Problem

Setting up a second instance of IBM Atlas eDiscovery Process Management(Atlas) for fail over purposes causes an application lock error.

Symptom

The application is down, login screen is inaccessible and a lock error appears in the logs.

Cause


When two instances of Atlas are running at the same time, the ApplicationLock mechanism will prevent both instances from accessing the same database.

Environment

Occurs in all environments.

Diagnosing The Problem


There will be an application lock error in the logs indicating another instance has tried to access the same database:

Error]-[Unable to lock application [PolicyAtlas] due to
[com.secretseal.policyatlas.service.exceptions.ApplicationLockException:
Lock for application [PolicyAtlas] is unavailable at this time.].]:
com.secretseal.policyatlas.service.exceptions.ApplicationLockException:
Unable to lock application [PolicyAtlas] due to
[com.secretseal.policyatlas.service.exceptions.ApplicationLockException:
Lock for application [PolicyAtlas] is unavailable at this time.].

Resolving The Problem

There is no fail-over functionality available in Atlas at this time. In order to achieve this, one server must be physically stopped, before you start the other.

[{"Product":{"code":"SS5JP8","label":"Atlas eDiscovery Process Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Data sources","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"6.0.1.3;6.0.1.2;6.0.1.1;6.0.1;6.0;5.0.1;4.5.2;4.5.1;3.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 June 2018

UID

swg21623932