Portal 8 CF03 Installation Fails on 'action-start-portal-server-standard' task

Technote (troubleshooting)


Problem

The Portal 8 installation executes a ConfigEngine script called 'action-start-portal-server-standard'. This script tries to start the server. It fails at this point - because the server is already started.

Symptom

In the ConfigTrace.log the following error is seen:

action-start-portal-server-standard:
[logmsg] [01/29/13 12:57:34.444 CET] EJPCA3163I: Starting Server
"WebSphere_Portal"
[echo] 'WebSphere_Portal' seems to be stopped.
[echo] Starting 'WebSphere_Portal'
[exec] ADMU0116I: Tool information is being logged in file
[exec]
/opt/IBM/WebSphere/wp_profile/logs/WebSphere_Portal/startServer.log
[exec] ADMU0128I: Starting tool with the wp_profile profile
[exec] ADMU3100I: Reading configuration for server:
WebSphere_Portal
[exec] ADMU3028I: Conflict detected on port 10025. Likely causes:
a) An instance of
[exec] the server WebSphere_Portal is already running
b) some other
[exec] process is using port 10025
[exec] ADMU3027E: An instance of the server may already be
running: WebSphere_Portal
[exec] ADMU0111E: Program exiting with error:
[exec]
com.ibm.websphere.management.exception.AdminException: ADMU3027E: An
[exec] instance of the server may already be running:
WebSphere_Portal
[exec] ADMU1211I: To obtain a full trace of the failure, use the
-trace option.
[exec] ADMU0211I: Error details may be seen in the file:
[exec]
/opt/IBM/WebSphere/wp_profile/logs/WebSphere_Portal/startServer.log
--- Exception Thrown ---


Cause

If the monitoring policy "Node Restart State" does not have the value "STOPPED", it fails at this point - because the server is already started.

Diagnosing the problem

In the ConfigTrace.log related to this install look for task 'action-start-portal-server-standard' and it will show the error:

[exec]
com.ibm.websphere.management.exception.AdminException: ADMU3027E: An
[exec] instance of the server may already be running:
WebSphere_Portal

Resolving the problem

The Monitoring Policy - "Node Restart State" - must be disabled as follows:-
1. Log in to the DMGR
2. Navigate to Servers -> Application Servers -> WebSphere_Portal ->
Java and Process Management -> Monitoring Policy
3. Change the value for "Node Restart State". It should be "STOPPED".
4. Save changes and synchronize the node.
5. Redo the CumulativeFix install.

Document information


More support for:

WebSphere Portal
Installation

Software version:

8.0, 8.0.0.0, 8.0.0.1

Operating system(s):

AIX, Linux, Solaris, Windows

Reference #:

1623892

Modified date:

2013-02-01

Translate my page

Content navigation