Identity Insight 64 bit pipeline startup error "[CANTOPEN] Unable to open oci70win_x64_cl-m.dll"

Technote (troubleshooting)


Problem(Abstract)

The Identity Insight pipeline is failing at startup when connecting to an Oracle database. The error given is "[CANTOPEN] Unable to open oci70win_x64_cl-m.dll"

Symptom

[sql:1868] CRIT: Exception: [CANTOPEN] Unable to open
oci70win_x64_cl-m.dll
[sql:1868] CRIT: CRITICAL ERROR:
[sql:1868] CRIT: {
[sql:1868] CRIT:  [SQL-00001]: [CANTOPEN] Unable to open
oci70win_x64_cl-m.dll:
[sql:1868] CRIT:  Failed to initialize database connection
[sql:1868] CRIT: }


Cause

The Identity Insight DLL (oci70win_x64_cl-m.dll) will not load if it cannot find the correct Oracle 64 bit DLL (oci.dll).

Environment

Windows 64 bit

Diagnosing the problem

Check what version of the Oracle OCI driver is. The Identity Insight 64 bit installation needs the 64 bit Oracle client.

Resolving the problem

Set the $ORACLE_HOME to the correct Oracle directory where the 64 bit OCI.dll is located. As another option, copy the OCI.dll to the $ISII/bin directory as a last step to make sure that Identity Insight will locate the 64 bit Oracle driver.

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Document information


More support for:

InfoSphere Identity Insight

Software version:

8.0

Operating system(s):

Windows

Reference #:

1623820

Modified date:

2013-03-19

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