QualityStage Match Designer displays an error when opening a Match Specification

Technote (troubleshooting)


Problem(Abstract)

Editing a QualityStage Match Designer Match Specification results in the following error: Error validating server connection to results database: Bad File name or number (52).

Cause

The Match Designer (MD) initialization process includes confirmation that the ODBC DSN (Data Source Name) specified in the MD Test Environment is operational on both the client and server systems. As part of this process, the path to the current DataStage/QualityStage (DS/QS) project must be identified on the server and then, using a Microsoft Visual Basic function, it is determined whether this path exists on the system where the Match Designer client is installed.

This function returns the reported error when it attempts to search a drive that does not contain any media (such as an empty CD drive) or when the referenced media contains a disk volume that is not longer mounted..

For example, this error will occur if all of the following conditions are met:

1) The DS/QS client and server are located on separate systems.
2) The current DS/QS project is located on the server system's D-drive.
3) The D-drive on the client system is a CD drive that does not contain a CD or is not mounted.

Resolving the problem

To determine which drive might be the issue, determine where the DataStage projects are on the server by finding the drive letter for the following DataStage/QualityStage server folder:


?:\IBM\InformationServer\Server\Projects\

Then ensure that the storage device that uses this same driver letter on the client is mounted or has a CD in it.

For example, here the projects are on the server's D-drive:

D:\IBM\InformationServer\Server\Projects\

So you would need to ensure that the D-drive on your client has a CD in it (if D is a CD drive) or is mounted (if D is a disk drive).

Doing this will satisfy the Visual Basic path search function's need for viable media and the error should not occur.


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Document information


More support for:

InfoSphere QualityStage

Software version:

8.5, 8.7, 9.1

Operating system(s):

Windows

Reference #:

1623814

Modified date:

2013-02-01

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