Technote (troubleshooting)
Problem(Abstract)
Application throwing following error. Indicating Unique Constraint Violation for YFS_Order_Date table
Symptom
IBM Sterling error logs are showing following error
<Errors>
<Error ErrorCode="YFC0001"
ErrorDescription="Record already exists in the database."
ErrorRelatedMoreInfo="" ErrorUniqueExceptionId="10.4.33.6013545680010810000000000021">
<Attribute Name="ErrorCode" Value="YFC0001"/>
<Attribute Name="ErrorDescription" Value="Record already exists in the database."/>
<Attribute Name="SQLStatement" Value="PREPARED STATEMENT - INSERT /*YANTRA*/ INTO YFS_ORDER_DATE(ORDER_DATE_KEY,ORDER_HEADER_KEY,ORDER_LINE_KEY,ORDER_RELEASE_KEY,DATE_TYPE_ID,REQUESTED_DATE,EXPECTED_DATE,ACTUAL_DATE,COMMITTED_DATE,CREATETS,MODIFYTS,CREATEUSERID,MODIFYUSERID,CREATEPROGID,MODIFYPROGID,LOCKID) values ( '201212031589532199544885','2012120315284799543981','2012120315284799543982',' ','YCD_COMPLETELY_SHIPPED_OR_CANCELLED','2012-12-03T15:53:21','2012-12-03T15:53:21','2012-12-03T15:53:21','2012-12-03T15:53:21','2012-12-03T15:53:21','2012-12-03T15:53:21','admin','admin','SterlingHttpTester','SterlingHttpTester',0 ) "/>
with stack trace:
:
:
at com.yantra.shared.dbclasses.YFS_Order_DateDBHome.insertNoKeyGen(YFS_Order_DateDBHome.java:994)
at com.yantra.shared.dbclasses.YFS_Order_DateBase.insertNoKeyGen(YFS_Order_DateBase.java:1472)
at com.yantra.shared.dbclasses.YFS_Order_DateDBHome.insert(YFS_Order_DateDBHome.java:912)
at com.yantra.omp.business.order.status.YFSStatusMileStoneCreator.insertOrUpdateOrderDateRecord(YFSStatusMileStoneCreator.java:328)
at com.yantra.omp.business.order.status.YFSStatusMileStoneCreator.createLineMSRecord(YFSStatusMileStoneCreator.java:217)
at com.yantra.omp.business.order.status.YFSStatusMileStoneCreator.createMilestoneRecords(YFSStatusMileStoneCreator.java:160)
at com.yantra.omp.business.order.status.YFSStatusMileStoneCreator.processMilestoneRecords(YFSStatusMileStoneCreator.java:59)
at com.yantra.omp.business.order.status.YFSMoveStatusManager.moveStatus(YFSMoveStatusManager.java:69)
:
:
Cause
This has been identified as a product defect under APAR IC89900.
Defect Fixed as part of 9.2 FP10
Diagnosing the problem
Validate error stack / message in log files
Resolving the problem
Apply 9.2 FP10 or above
Rate this page:
Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.