Using Rhapsody 8 Help with Cisco VPN results in not being able to view Help contents

Technote (troubleshooting)


Problem(Abstract)

Using IBM Rational Rhapsody 8.0.1 with Cisco AnyConnect VPN 2.4.1012 will not connect the Rhapsody Help contents from the Help System if launched from your home.

Symptom

You are working from home and using Rhapsody 8.0.1. You need to connect to your license server as you are using token licensing. You must use your AnyConnect VPN 2.4.1012 from Cisco, but when you open the Rhapsody Help system, the contents are not visible.


Cause

The cause is that Rhapsody 8.x uses IBM Java version 7.

There is a known issue with Java 7 using IPv6; this is not compatible with this Cisco application.


Resolving the problem

WORKAROUNDS:

  • Change the -vm settings in the help.ini to point to Java 6

  • Add the following line in the help.ini to use IPv4 (which Cisco does support):

    -Djava.net.preferIPv4Stack=true

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Document information


More support for:

Rational Rhapsody
Rational Rhapsody Developer

Software version:

8.0.1

Operating system(s):

Windows

Reference #:

1623668

Modified date:

2013-02-01

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