Rational Team Concert client and server compatibility

Technote (FAQ)


Question

Which version of IBM Rational Jazz Team server is compatibile with my IBM Rational Team Concert (RTC) client version?

Cause

The information in this technote is meant to provide details about the compatible versions of RTC clients and servers to assist with upgrade and installation planning.

Answer

For version 4.0.5 and above, refer to the IBM Rational Collaborative Lifecycle Management Knowledge Center under the topic of Client and server version compatibility where a similar table is provided to show client and server compatibility.

Rational Team Concert Client and Server Compatibility

Eclipse and Visual Studio client
Jazz Team Server
4.0.4
4.0.3
4.0.2
4.0.1
4.0
3.0.1.x
3.0
2.x
4.0.4
Y
N
N
N
N
N
N
N
4.0.3
Y
Y
N
N
N
N
N
N
4.0.2
Y
Y
Y
N
N
N
N
N
4.0.1
Y
Y
Y
Y
N
N
N
N
4.0.0.x
Y
Y
Y
Y
Y
N
N
N
3.0.1.x
Y
Y
Y
Y
Y
Y
N
N
3.0
Y
Y
Y
Y
Y
Y
Y
N
2.x
N
N
N
N
N
N
N
Y

  • When a mismatch occurs, a friendly dialog explains the version mismatch. You have the option to customize the message to direct users where to download new clients.
  • RTC users needing to access both v2.x and v3.x/v4.x servers must use separate RTC Eclipse clients.
  • RTC users needing to access both v3.x and v4.x servers must use an RTC 3.x client.
  • RTC repository workspace is compatible from v2.x or v3.x to v4.x client.
  • RTC Eclipse clients support shell sharing with other Eclipse versions. See the Detailed system requirements for specific Eclipse versions supported.
  • IBM Rational Quality Manager (RQM) and Rational Requirements Composer (RRC) 4.x clients are web browser based.
  • RTC users needing to access both v2.x and v3.x servers must use separate RTC Eclipse clients.
  • Your RTC repository workspace from version 2.x or version 3.0 continues to work with version 3.0.1 clients without the need to reload all your source code.
  • The RTC 3.0.1 Eclipse client can run in Eclipse 3.5.x or 3.6.x. (3.5.2 is bundled).


Additional information can be found in the IBM Rational Team Concert Knowledge Center under the topic of Client and server version compatibility.

Leverage the Jazz Community

The Jazz based products have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki.
Refer to technote 1319600 for details and links.

Rate this page:

(0 users)Average rating

Document information


More support for:

Rational Team Concert
General Information

Software version:

2.0, 2.0.0.1, 2.0.0.2, 3.0, 3.0.1, 3.0.1.1, 3.0.1.2, 3.0.1.3, 3.0.1.4, 3.0.1.5, 4.0, 4.0.0.1, 4.0.0.2, 4.0.1, 4.0.2, 4.0.3, 4.0.4

Operating system(s):

AIX, Linux, Windows, i5/OS, z/OS

Reference #:

1623665

Modified date:

2013-12-23

Translate my page

Machine Translation

Content navigation