Connect:Direct File Agent sending duplicate files after network outage

Technote (troubleshooting)


Problem(Abstract)

Connect:Direct File Agent sending duplicate files after network outage, no error messages in the stats log file or FA log file.

Symptom

Connect:Direct File Agent sending duplicate files after network outage, no error messages in the stats log file or FA log file.


Cause

The process invoked by IBM Sterling Connect:Direct was performing a wildcard copy of all files in the watch directory. As each file in the watch caused the same wildcard copy process to be invoked each file was sent multiple time

Environment

Connect:Direct File Agent

Resolving the problem

The recommendation would be to process each file individually rather than attempting to bulk transfer files by passing the sourcefile and destinationfile variables from the FileAgent configuration to the invoked process.

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Document information


More support for:

Sterling Connect:Direct
Maintenance

Software version:

All

Operating system(s):

All, Windows

Reference #:

1623348

Modified date:

2013-02-08

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