Technote (troubleshooting)
Problem(Abstract)
Attempts to export (slice or snapshot) to Excel from TM1Web result in an error. This could occur with either websheets or cube views.
Symptom
Error seen in GUI:
Message from webpage
Exception from HRESULT: 0x80010108
May also see an error similar to the following in the tm1excelservice.log:
2013-01-03 12:00:30,346 [6] ERROR Applix.TM1.ExcelApp.ExcelApplication
- Failed to close xls file: The object invoked has disconnected from
its clients. (Exception from HRESULT: 0x80010108 (RPC_E_DISCONNECTED))
Cause
This is likely caused by an Excel licensing issue on the Web server.
Diagnosing the problem
Turn on debug logging, per technote link below, and this should give an indication of the problem. Once the logging has been turned on there will likely be a debug message similar to the following, which explains that it is an Excel licensing issue:
2013-01-03 12:00:30,346 [6] DEBUG Applix.TM1.ExcelApp.ExcelApplication - failed to make excel invisible System.Runtime.InteropServices.COMException (0x800A03EC): This command is unavailable because the license to use this application has expired.
Resolving the problem
Correct the Excel license issue on the Web server.
Related information
Debug Web logging - technote 1459780
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