KPI history export file cannot be imported

Technote (troubleshooting)


Problem(Abstract)

When you export the KPI history for a model and try to import it on a different system, the data does not get imported, even though the process states CWMKP1068I: SUCCESS Import complete.

Cause

The exported file is encoded in UTF-16, while the import expects a UTF-8 encoded file.

Resolving the problem

After exporting you should convert the file to UTF-8. This can be done by using the iconv command like this:

iconv -f UTF-16 -t UTF-8 -o /tmp/kpi_history_export_utf8.csv /tmp/kpi_history_export.csv

Alternatively, you can open the file in VI, and use the following commands:
:e ++enc=utf16le
:write ++enc=utf-8 kpi_history_export_utf8.csv

Related information

Exporting KPI history
Importing KPI history

Cross reference information
Segment Product Component Platform Version Edition
Business Integration IBM Business Monitor Not Applicable Linux, Windows 8.5, 8.0, 7.5.1, 7.5

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Document information


More support for:

WebSphere Business Monitor

Software version:

7.0, 7.5, 7.5.1

Operating system(s):

Linux, Windows

Reference #:

1623079

Modified date:

2013-01-22

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