After your user session times out, sometimes the system displays an error in the IBM Intelligent Transportation solution portal instead of the login page

Technote (troubleshooting)


Problem(Abstract)

After your user session times out, sometimes the system displays an error message in the IBM® Intelligent Transportation solution portal, rather than redirecting you to the Smarter Cities Solutions login page.

Symptom

When you are using the IBM Intelligent Transportation solution portal, you are automatically logged out after a period of inactivity and redirected to the Smarter Cities Solutions login page. By default, the specified timeout period is set to 600 seconds. The session timeout might be longer depending on the configuration of your deployment.

Sometimes, after being inactive for more than the specified timeout period, you are not redirected to the login page as expected and an error is displayed instead. This can happen in the solution portal pages of both IBM® Intelligent Operations for Transportation and IBM® Intelligent Transit Analytics.

For example, if your session times out when you are viewing events on the Operator: Traffic page, the following error is displayed:

Error retrieving event data. Notify your system administrator if this error persists.

The following message is displayed above the map in the Current Traffic Conditions portlet:

Loading Content...

When this problem occurs, if you try to load or refresh the traffic data that is displayed on the map, the system does not respond. The traffic data does not display and there are no error messages to indicate that there is a problem loading the traffic data on the map.

Cause

The error occurs if the user session times out after the specified timeout period.

There are two timeout configuration settings that you can configure for IBM Intelligent Transportation. One is set in the IBM Intelligent Transportation solution portal. The second configuration option is the Tivoli® Access Manager WebSEAL timeout setting in the IBM® Intelligent Operations Center base architecture environment.


Resolving the problem

To resolve this issue, restart the browser session, and then log on to the solution portal again.

Cross reference information
Segment Product Component Platform Version Edition
Smarter Cities IBM Intelligent Transportation IBM Intelligent Transit Analytics Linux Red Hat - xSeries 1.5.0 All Editions

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Document information


More support for:

IBM Intelligent Transportation
IBM Intelligent Operations for Transportation

Software version:

1.5.0

Operating system(s):

Linux Red Hat - xSeries

Software edition:

All Editions

Reference #:

1623061

Modified date:

2013-03-14

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