IBM Support

SOAPFaults and connection resets with the error code 0x00630004 occuring when message exceeds the defined limit

Troubleshooting


Problem

When the 'Attachment Byte Count Limit' was defined, why do I see in some cases SOAPFaults and in other cases connection resets with the same error code 0x00630004 if the message exceeds the defined limit?

Cause

This is due to the current design of the device. The DataPower SOA Appliance is optimized to not waste resources on bad transactions.

Resolving The Problem

If the full attachment can be buffered before DataPower notices the error (i.e. the attachment exceeding the size limit imposed by the attachment-byte-count setting) an error message will be logged and a SOAPFault will be sent to the client. However, if DataPower is still reading the attachment when the configured limit is reached, it will close/reset the connection rather than wasting time, CPU and memory reading it all in.

For example:

If the 'Attachment Byte Count Limit' is set to 100kb, a messages of ~105kb will generate a SOAPFault whereas a message of ~200kb will cause a connection reset.


In either case the DataPower appliance will log an error message with error code below:

"0x00630004 - An attachment exceeded the size limit imposed by attachment-byte-count."

[{"Product":{"code":"SS9H2Y","label":"IBM DataPower Gateway"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"General","Platform":[{"code":"PF009","label":"Firmware"}],"Version":"4.0.2;4.0.1;5.0.0;6.0.0;6.0.1","Edition":"Edition Independent","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
08 June 2021

UID

swg21623058