Troubleshooting
Problem
Installation of DB2 during the Tivoli Storage Manager server install fails with errors ACUOSI0050E and RC 1639
Symptom
Review of the DB2.log shows the following error:
<errorMessage>
[com.ibm.ac.si.ap.action.ExternalCommandActionException:
ACUOSI0050E External command action failed with return code 1639.
Invocation string: [C:\TSM Install\COI\PackageSteps/DB2/FILES\ESE\image/setup.exe, /f, /i, en, /l,
C:\Program Files\Tivoli\TSM\_uninst\plan\logs/db2_inst.log, /u,
C:\Program Files\Tivoli\TSM\_uninst\plan\tmp/Prefix_ResponseFile.txt],
com.ibm.ac.common.hosts.CreationFailedException: : ]
</errorMessage>
Cause
RC 1639 means that an invalid argument was passed to setup.exe.
This error can have multiple causes, two common ones are:
1) Having a space in the install directory path.
The install path in the above example is 'C:\TSM Install', which is not valid.
The install path cannot contain any spaces.
2) The extract path for the install is too long, resulting in exceeding the inherent 255 character limit Windows imposes for filenames.
Diagnosing The Problem
Review the DB2.log for the error.
Resolving The Problem
Use an install path which is short and does not contain any spaces, for example:
C:\TSM_Install
Product Synonym
TSM
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21622250