CMN8025E NullPointerException messages when inbound MQ queues do not get processed

Technote (troubleshooting)


Problem(Abstract)

After setting up WebSphere Commerce to work with WebSphere MQ, messages placed on the inbound MQ queues appear to be stuck and do not get processed by the server. Error: com.ibm.commerce.messaging.listener.TransportAdapterSerialDispatcher process() CMN8025E, NullPointerException.

Symptom

When reviewing the SystemOut.log file, there is a NullPointerException similar to the following snippet:

[6/24/12 21:31:27:403 EDT] 0000005d CommerceSrvr  E com.ibm.commerce.messaging.listener.TransportAdapterSerialDispatcher process() CMN8025E: The request ID:c1d4d840d8d4c1e2c7d7d9c4404040404fe72e812000c302 failed with error com.ibm.wsspi.uow.UOWException: java.lang.NullPointerException

at com.ibm.ws.uow.UOWManagerImpl.runUnderNewUOW(UOWManagerImpl.java:1059)

at com.ibm.ws.uow.UOWManagerImpl.runUnderUOW(UOWManagerImpl.java:626)

at com.ibm.commerce.messaging.listener.TransportAdapterSerialDispatcher.process(TransportAdapterSerialDispatcher.java:513)

at com.ibm.commerce.messaging.listener.TransportAdapterSecurityPriviledgeAction.run(TransportAdapterSecurityPriviledgeAction.java:55)

at com.ibm.commerce.messaging.listener.TransportAdapterSerialDispatcher.run(TransportAdapterSerialDispatcher.java:130)

at com.ibm.commerce.threadmanagement.internal.BaseWork.run(BaseWork.java:139)

Cause

There might be an issue with the ActivitySession service configuration, or it has not been started.

Resolving the problem

Use the steps provided in the Information Center to ensure the ActivitySession service is configured correctly, in particular that the service is set to be enabled at server start up. See the following document for more information:


Configuring WebSphere Application Server for use with WebSphere MQ


Rate this page:

(0 users)Average rating

Document information


More support for:

WebSphere Commerce Enterprise
Messaging

Software version:

7.0

Operating system(s):

AIX, IBM i, Linux, Solaris, Windows, i5/OS

Software edition:

All Editions

Reference #:

1622131

Modified date:

2013-02-15

Translate my page

Machine Translation

Content navigation