Technote (troubleshooting)
Problem(Abstract)
Importing large business glossary files, such as the XML files provided with IBM Industry Models, might fail due to exceeding the timeout values set in WebSphere Application Server and InfoSphere Information Server. You can change these values so that the import succeeds.
Symptom
You receive an error message while importing a file. For example, with InfoSphere Business Glossary 8.7 or 9.1, you might receive the following messages:
Errors occurred while importing data from the filetype.
-
where
filetype is XML, CSV or XMI.
or
-
Undefined error occurred.
Cause
Time for the import process exceeds timeout values set in WebSphere Application Server and InfoSphere Information Server.
Resolving the problem
You must raise timeout values that are configured in WebSphere Application Server and InfoSphere Information Server. In the example used in this document, we have set maximum value to 24 hours, but you can use a timeout value that fits your needs.
1. To configure the higher timeout values in WebSphere Application Server:
- Log in to the WebSphere Application Server Integrated Solutions Console.
- Remove any per-session timeout:
- Under Servers, select WebSphere application servers > server1.
- Under Container settings, select Web Container Settings > Web container.
- Under Additional Properties, select Session management.
- Under Session timeout, select No timeout.
- Click OK.
- Under Security, select Global security.
- Under Authentication, select LPTA.
- Set the LTPA timeout to 1440.
- Click OK.
- Under Servers, Select Application servers > server1.
- Select the Runtime tab.
- Select Transaction service. Set the Total transaction lifetime timeout to 86400.
- On the same page, set the Maximum transaction timeout to 86400.
- Click OK.
D. Raise the transaction timeouts:
E. Click Save in the Messages box near the top of the window to save the changes to the master configuration.
2. To configure the higher timeout value in InfoSphere Information Server:
- Log in to the InfoSphere Web Administrative Console.
- Click the Administration tab.
- Select Session Management > Active Sessions, then select the session you want to change.
- Select Global Session Properties, then set the Inactive Session Timeout to 86400.
- Click Save.
| Segment | Product | Component | Platform | Version | Edition |
|---|---|---|---|---|---|
| Information Management | InfoSphere Information Server | AIX, HP-UX, Linux, Solaris, Windows | 9.1, 8.7.0.1, 8.7, 8.5.0.3, 8.5.0.2, 8.5.0.1, 8.5 |
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