Technote (troubleshooting)
Problem
When a user attempts to open an instance of a repeating meeting, an inordinate delay is experienced.
This is verified when using CLIENT CLOCK debug in the Notes Client, as the following extract would show a very long delay in milliseconds following the POLL_DEL_SEQNUM reference:
[13AC:0011-121C:newmail] (235-51 [235]) POLL_DEL_SEQNUM: (Connect to ServerName/Org: 4294967042 ms) (OPEN_SESSION: 1 ms)
4294966933 ms. [110+28=138] (No error)
Symptom
A user complains of experiencing repeated long delays when opening meetings in particular in the Notes Client
Cause
The following was noticed in a NSD collected at a time when the issue was reproduced:
############################################################
### FATAL THREAD 1/17 [ NLNOTES: 0e40: 03d4]
### FP=0x001390ac, PC=0x63051e8c, SP=0x00138efc
### stkbase=00140000, total stksize=237568, used stksize=28932
### EAX=0x0979a944, EBX=0x9701211f, ECX=0x0979a944, EDX=0x0979a314
### ESI=0x00000000, EDI=0x6e6f6900, CS=0x0000001b, SS=0x00000023
### DS=0x00000023, ES=0x00000023, FS=0x0000003b, GS=0x00000000
Flags=0x00010246
Exception code: c0000005 (ACCESS_VIOLATION)
############################################################
@[ 1] 0x63051e8c nnotesws.CEdBoxDataMixin::GetRunFlags+28
(0,60,31,ffffffb8)
@[ 2] 0x63151c68 nnotesws.CEdParagraphBoxData::Paint+1624
(139294,139260,1391b0,0)
@[ 3] 0x630e3026 nnotesws.@DocPaintUpdate@8+1718 (95a7018,639dd589)
@[ 4] 0x63915758 nnotesws.@DocPaintIfModifiedNoFrame@4+88 (0)
@[ 5] 0x630503ff nnotesws.@DocWindowsMessage@24+20735
(0,0,13967c,139670,0,0)
@[ 6] 0x6304a2ee nnotesws.DocRichTextWndProc@16+238 (95a7018,849,0,0)
[ 7] 0x7e418734 USER32.GetDC+109 (6304a200,760aac,849,0)
[ 8] 0x7e418816 USER32.GetDC+335 (0,6304a200,760aac,849)
[ 9] 0x7e4189cd USER32.GetWindowLongW+295 (139790,0,1397b4,630b9f1b)
[10] 0x7e418a10 USER32.DispatchMessageW+15 (139790,1,401b0,63020000)
@[11] 0x630b9f1b nnotesws.NEMMainLoop@4+811 (4013a0)
@[12] 0x00401a41 NLNOTES.WinMain@16+1697 (630f71e0,0,16231d,0)
@[13] 0x00402721 NLNOTES.WinMainCRTStartup+389
(11ca94,7c90e920,7ffd9000,8054b6ed)
[14] 0x7c817077 kernel32.RegisterWaitForInputIdle+73
(40259c,0,78746341,20)
Environment
Notes/Domino 8.5.x
Diagnosing the problem
Collect CLIENT CLOCK debug extracts and also a generated NSD once the issue is reproduced.
Resolving the problem
The NSD extract above correlates with SPR ICRE8EKSDK. This SPR is resolved in Notes/Domino 8.5.4 onwards, so it is recommended to upgrade on this basis.
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