Upgrade creates larger index

Technote (troubleshooting)


Problem(Abstract)

After migrating from IBM Rational Collaborative Lifecycle Management (CLM) 3.x, 4.0, or 4.0.0.x to CLM 4.0.1, the RDF indexes are much larger in size and possibly corrupt.

Symptom

The most immediate symptom is a significantly increased disk size of the index. The problem only affects resources that existed before the migration. New resources after migration are not affected. The default location is conf/<appName>/indices.

A secondary symptom is an initial sluggishness for a number of operations, when 4.0.1 starts for the first time after the upgrade. Queries on only pre-migration data respond. Whereas queries on new data can either take a much longer time or even time out. If queries time out, the corresponding application log files contain warning or error messages in this regard. See defect 244504 Error deploying predefined templates after upgrading from 4.0 to 4.0.2... for an instance of this symptom.

In rare cases, the 4.0.1 index is actually invalid and causes queries to return the wrong results. If this happens, the effect is duplicate results. See defect 36270 A new ontology's Namespace Prefix has cardinality 2 after a server upgrade for an instance of this symptom.


Cause

The 4.0.1 and 4.0.2 RDF index providers keep the index size in the RDF index itself. However, version 4.0 and older keeps the index size only in an external meta-properties file. The effect is that in 4.0.1, Jazz believes that the 4.0 (or older) index is empty and therefore reinserts the old data. For details of the cause, see defect 245220 Migration to 4.0.1 skips over the index size .....


Resolving the problem

You can avoid or resolve this problem in the following two ways dependent on your environment:.

  • If you run 3.x, 4.0 or 4.0.0.x and plan to upgrade to 4.0.1, you must upgrade to 4.0.2 or a later release instead.
  • If you have already upgraded to 4.0.1 and see the index issues, the only way to fix is the following.


    1. Shut down the CLM server completely.


    2. Run repotools-application reindex all.

CLM 4.0.2 and later releases address this problem.

Leverage the Jazz Community

Jazz and Rational Team Concert have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki.
Refer to technote 1319600 for details and links.

Related information

A Japanese translation is available


Cross reference information
Segment Product Component Platform Version Edition
Software Development Rational Quality Manager Team Server AIX, Linux, Solaris, Windows, z/OS 3.0.1, 3.0.1.1, 3.0.1.2, 3.0.1.3, 3.0.1.4, 3.0.1.5, 4.0, 4.0.0.1, 4.0.1
Software Development Rational Requirements Composer Team Server Windows, Linux, z/OS 3.0.1, 3.0.1.1, 3.0.1.2, 3.0.1.3, 3.0.1.4, 3.0.1.5, 4.0, 4.0.0.1, 4.0.1

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Document information


More support for:

Rational Team Concert
Team Server

Software version:

3.0, 3.0.1, 3.0.1.1, 3.0.1.2, 3.0.1.3, 3.0.1.4, 4.0, 4.0.0.1, 4.0.1

Operating system(s):

AIX, Linux, Windows

Reference #:

1620879

Modified date:

2014-04-01

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