Flash (Alert)
Abstract
This alert is meant to inform you of an issue that can occur after migrating from IBM Rational Collaborative Lifecycle Management (CLM) 3.x, 4.0, or 4.0.0.x to CLM 4.0.1 where the size of the RDF indexes (by default located in conf/<appName>/indices) will be substantially larger in size and could be corrupted leading to possibly inaccurate query results.
Content
Updates:
April 1, 2013: Changed version referenced in the following statement from 4.0.1.1 to 4.0.2:
This problem is addressed in CLM 4.0.2 and later releases.
February 4, 2013: Clarified information about requesting a testfix.
Cause
The 4.0.1 and 4.0.2 RDF index providers keep the index size in the RDF index itself. However, in 4.0 and before the index size was only kept in an external meta properties file. The effect is that in 4.0.1, Jazz will believe the 4.0 (or older) index is empty, causing it to reinsert the old data. More details of the cause can be found in defect 245220.
Symptoms
The most immediate symptom is a significantly increased disk size of the index. The problem only affects resources which existed before the migration. Newly added resources after migration are not affected.
A secondary symptom is an initial sluggishness for a number of operations when 4.0.1 starts for the first time after the upgrade. Although queries will keep responding when only dealing with pre migration data, queries on newly added data may either take a significantly longer time or even time out. If queries time out, the corresponding application log files will contain warning or error messages in this regard. Defect 244504 shows an instance of this symptom.
In some rare cases, the 4.0.1 index will actually be invalid and cause some queries to return the wrong results. If this happens, the effect will be duplicate results. Defect 36270 shows an instance of this symptom.
Resolution
This problem can be avoided or resolved in the following two ways dependant upon your environment:
- If you are running 3.x, 4.0 or 4.0.0.x and are planning to upgrade to 4.0.1, you should contact IBM Rational Support to request a testfix for defect 245220 to apply to the newly installed 4.0.1 instance prior to the data migration from the previous 3.x, 4.0 or 4.0.0.x release.
- If you have already upgraded to 4.0.1 and notice the symptoms described in this technote, then the problem can only be fixed by running repotools-application reindex all. Ensure the CLM server is completely shut down before running the command.
This problem is addressed in CLM 4.0.2 and later releases.
Jazz and Rational Team Concert have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki. |
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Related information
A Japanese translation is available
| Segment | Product | Component | Platform | Version | Edition |
|---|---|---|---|---|---|
| Software Development | Rational Quality Manager | Team Server | AIX, Linux, Solaris, Windows, z/OS | 3.0.1, 3.0.1.1, 3.0.1.2, 3.0.1.3, 3.0.1.4, 3.0.1.5, 4.0, 4.0.0.1, 4.0.1 | |
| Software Development | Rational Requirements Composer | Team Server | Windows, Linux, z/OS | 3.0.1, 3.0.1.1, 3.0.1.2, 3.0.1.3, 3.0.1.4, 3.0.1.5, 4.0, 4.0.0.1, 4.0.1 |
Product Alias/Synonym
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