Troubleshooting
Problem
Attempt to delete a DataStage job received "Unable to delete the item(s). Delete object for "\JobName' failed. Cannot find job
Cause
This error occurs when DataStage was not shut down successfully causing job file corruption.
Resolving The Problem
To resolve the issue:
- Use the SyncProject tool
The SyncProject tool needs to be run on the DataStage server to fix the corrupted files.
For version 8.0.1 and 8.1, the SyncProject tool is not available for download.
Please contact IBM InfoSphere Information Server Support to obtain the SyncProject tool and instruction on running the tool.
For version 8.5, 8.7, and 9.1, the SynchProject tool is available within InfoSphere Information Server and is located under:
- /opt/IBM/InformationServer/ASBNode/bin (UNIX/Linux default location)
- C:/IBM/InformationServer/ASBNode/bin (Windows default location)
Additional information on using the SyncProject tool to recover projects can be found in InfoCenter:
Related Information
[{"Product":{"code":"SSVSEF","label":"IBM InfoSphere DataStage"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.1;8.7;8.5;8.1;8.0.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
16 June 2018
UID
swg21620508