ITCAMfTx RPT scripts do not playback after restarting T6 agent box

Technote (troubleshooting)


Problem(Abstract)

RPT scripts do not playback anymore after reboot of the ITCAMfTx environment

Symptom

One can see errors in the agent robotic BWM/logs as follows :

- Error BWMPB0106E Initialization failed for script type ...
- Error BWMRT0100E Could not playback profile ....
- Error BWMRT0101E Could not playback profile .... Failed to initialize the script.


Cause

Installation and configuration of ITCAMfTx environment was set up to run with a non-root user id.

Environment

ITCAMfTx v7.1 RRT - T6 robotic agent running on Linux OS

Diagnosing the problem

Examine directory listings (ls command) of the T6 agent regarding user configuration settings

Resolving the problem

After restart of the T6 RRT agent box, all scripts in directory /opt/IBM/ITM/tmaitm6/app/RPT/scripts
are owned by root, although installation and configuration of ITCAM environment was set up to run with non-root user id.

So changing the owner ID (using "chown" command) from root to the appropriate non-root user id of the above scripts files will solve the problem.

Historical Number

41324
122
000

Product Alias/Synonym

ITCAMfTx TCAMfTx CAMfTx ITCAMfTRANSACTIONS ITCAM4TRANSACTIONS

Rate this page:

(0 users)Average rating

Document information


More support for:

Tivoli Composite Application Manager for Transactions
ITCAM TRANSACT RRT 5724S79RR v710

Software version:

7.1, 7.2, 7.3, 7.4

Operating system(s):

Linux

Reference #:

1620110

Modified date:

2014-11-10

Translate my page

Machine Translation

Content navigation