Installing Rhapsody results in a hang during MSI installation

Technote (troubleshooting)


Problem(Abstract)

Attempts to install IBM Rational Rhapsody result in a hang after selecting an edition to install.

Symptom

You should apply the solution described in this technote if all the following conditions are met:

  • Installation process stop responding at edition selection page in the wizard.

  • There is no MSI error found in MSI log. The content of log file may end abruptly as below:

    Log Output (example):
    Action ended 9:28:34: updateAllUsersPathUI. Return value 1.
    MSI (c) (64:78) [09:28:34:348]: Doing action: InstallWelcome
    Action start 9:28:34: InstallWelcome.
    MSI (c) (64:68) [09:28:34:426]: Note: 1: 2205 2:  3: _RemoveFilePath
    MSI (c) (64:68) [09:28:38:130]: Note: 1: 2756 2: GroupName
    MSI (c) (64:68) [09:28:38:130]: Note: 1: 2756 2: RhapsodyGatewayGroupName
    MSI (c) (64:68) [09:28:38:130]: Note: 1: 2756 2: DocumentationGroupName
    MSI (c) (64:68) [09:28:38:130]: Note: 1: 1402 2: HKEY_CLASSES_ROOT\.1 3: 2
    MSI (c) (64:68) [09:28:38:146]: Note: 1: 2262 2: Extension 3: -2147287038
    MSI (c) (64:68) [09:28:38:146]: Note: 1: 2262 2: Extension 3: -2147287038
    MSI (c) (64:68) [09:28:38:146]: Note: 1: 2262 2: Extension 3: -2147287038
    MSI (c) (64:68) [09:28:38:146]: Note: 1: 2262 2: Extension 3: -2147287038
    MSI (c) (64:68) [

  • You can not resolve the issue using Microsoft Fix it solution available at Microsoft Fix it Solution Center.


Cause

This problem was identified to occur if the versions of msiexe.exe and msihnd.dll don't match.


<example>
msiexe.exe -> v4.5.6001.22159
msihnd.dll -> v3.1.4001.5512


Diagnosing the problem

How to collect MSI log:

You can collect MSI log by installing the product with the command below:

 msiexec /i <rhapsody installer>.msi /lv c:\temp\log.txt


How to check version of msiexe.exe and msihnd.dll:

You can check the version of msiexe.exe and msihnd.dll currently used in your system by navigating to the system folder where these files are stored and open the property page of these files by Right Click > Properties.

Resolving the problem

It is necessary to unify the version of msiexe.exe and msihnd.dll in order to resolve this installation issue.

One solution is to re-install Windows Installer.

Related information

Fix it (diagnostics tool for installation problems)
Windows Installer 4.5 is available

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Rhapsody
Installation

Software version:

7.5, 7.5.0.1, 7.5.1, 7.5.1.1, 7.5.2, 7.5.2.1, 7.5.3, 7.5.3.1, 7.5.3.2, 7.5.3.3, 7.6, 7.6.0.1, 7.6.1, 7.6.1.1, 7.6.1.2, 8.0, 8.0.1

Operating system(s):

Windows

Reference #:

1620082

Modified date:

2013-01-15

Translate my page

Machine Translation

Content navigation