Question & Answer
Question
How do you install the IBM BI Cognos 10 10.1.1 FixPack 1 with IBM Rational Insight 1.1.
Cause
This procedure is not documented.
Answer
Here is the procedure to install and apply the FixPack to Insight 1.1:
Install the Cognos 10 BI 10.1.1 Fix Pack 1
- Back up your Rational Insight data and files. For information about backing up data, see backing up your data.
- Download the platform specific Fix Pack at Cognos Business Intelligence 10.1.1 Fix Pack 1
- Unzip the Fix Pack to a local directory, <cognos_fixpack_dir>.
- Shut down the Rational Insight report server WebSphere Application Server service.
- For Windows, run <cognos_fixpack_dir>\win32\issetup.exe.
For Linux, run <cognos_fixpack_dir>/linuxi38632/issetup.
- Select the installation language, for example, English, and click Next.
- Select I agree to accept the license agreement and click Next.
- Select the <insight_install_dir>/cognos directory, for example C:\Program Files\IBM\Rational Insight\cognos on Windows, and click Next.
- Click Yes to backup the files to be replaced.
- Review the installation summary and click Next to start the installation.
- Click View the summary-error log and verify that there are no errors.
- Click Finish to exit the installer.
Restore the Rational Insight 1.1 skin and supporting files
- Download the file insight11_cognos1011_fp1.zip located on jazz.net Document instructions for applying Cognos 10.1.1 FixPack 1 to Insight 1.1 The file is located on the links tab.
- Extract its content to <insight_install_dir> and overwrite the existing files.
Rebuild and redeploy the Rational Insight 1.1 Report Server Web application
- Back up the <insight_install_dir>/cognos/p2pd.ear file.
- Open a command prompt.
- Navigate to <insight_install_dir>/cognos/war/p2pd.
For example, C:\Program Files\IBM\Rational Insight\cognos\war\p2pd.
. - Either run build -Dcontext_root=reporting ear
or build -Dcontext_root=insight ear
This depends on the Web application root context you specified when you installed Rational Insight 1.1 or upgraded Rational Insight 1.0.1.1 to 1.1.
- Start the Rational Insight report server WebSphere Application Server service.
- Start WebSphere Application Server console and log in.
- Click Applications > Application Types > WebSphere enterprise applications.
- Select IBM Cognos and click Stop.
- Select IBM Cognos again and click Uninstall.
- Click OK to uninstall the IBM Cognos Web application.
- Click Save to the save the changes to the WebSphere Application Server master configuration.
- Shut down the Rational Insight report server WebSphere Application Server service.
- Go to the file system and delete the following directories:
- <insight_install_dir>/AppServer/profiles/RationalReport/temp/RationalReportNode01/RationalReportServer/IBM_Cognos
- <insight_install_dir>/AppServer/profiles/RationalReport/installedApps/<cellName>/IBM Cognos.ear
- Start the Rational Insight report server WebSphere Application Server service.
- Start WebSphere Application Server console, log in and click Install to install a new Web application.
- Click Browse, select <insight_install_dir>/cognos/p2pd.ear and click Next.
For example, C:\Program Files\IBM\Rational Insight\cognos\p2pd.ear.
- Click Next to advance past the next four wizard pages.
- Click Finish.
- Click Save to the save the changes to the WebSphere Application Server master configuration.
- Log out of WebSphere Application Server console.
- Restart the Rational Insight report server WebSphere Application Server service.
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Document Information
Modified date:
16 June 2018
UID
swg21619726