IBM Support

"Could not create the view... Automation error ... The service did not start due to a logon failure" when click "Maintain - Jobs - Define" or use other JAVA-based functions

Troubleshooting


Problem

User clicks "Maintain - Jobs - Define". User receives error message. User receives similar error message when performing other Java-based functionality.

Symptom

Could not create the view: !Could not create controller of type com.ibm.cognos.ccr.integration.internal.job.ui.JobDialogDefinitionViewController for composite class com.ibm.cognos.ccr.integration.internal.job.ui.JobDialogDefinitionUI!

java.lang.reflect.InvocationTargetException
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
<...>

at com.ibm.cognos.ccr.integration.application.AbstractLifeCycleManager.getModel(AbstractLifeCycleManager.java:233)
... 68 more
Caused by: com.ibm.cognos.ccr.common.WebServiceConnectionException: exceptionId=ERR.ANY.WEBSERVICECONNECTIONEXCEPTION.CANNOT_EXECUTE_SERVICE, argument(s)=[FAIL: Message: Automation error
The service did not start due to a logon failure. Source: FrJavaProxyB, <http>://COL43-5414-2609/ibmcognos/controllerserver/CCRWS.asmx, ?]
at com.ibm.cognos.ccr.ccrws.JAXWSClient.executeTask(JAXWSClient.java:107)

Cause

There are many potential causes for the generic message "Could not create the view".

  • TIP: For more examples, see separate IBM Technote #1612000.

This IBM Technote specifically relates to the scenario where the error message contains the message " Automation error The service did not start due to a logon failure".
  • In this scenario, the cause is that an incorrect user and/or password has been used for the Windows service "IBM Cognos Controller Java Proxy".

Environment

The above error message is based on Controller 10.1.1.

Resolving The Problem

The solution varies slightly depending on what version of Controller you are using:

  • Controller 10.2.1 (and later): Modify the Windows service "IBM Cognos Controller Java Proxy" to logon as the 'Local System' account
  • Controller 10.2.0 (and earlier): Modify the username/password used for Windows service "IBM Cognos Controller Java Proxy", running on the Controller application server.

Steps:
  • For Controller 10.2.1 (and later):

  • 1. Logon to the Controller application server as a Windows administrator
    2. Right-click on "My Computer" and choose "Manage"
    3. Expand "Services and Applications" and "Services"
    4. Double-click on "IBM Cognos Controller Java Proxy"
    5. Click tab "Log On"
    6. Modify the settings for "Log on as" to be 'Local System account':

    7. Click OK
    8. Click "General" tab.
    9. Click "Stop"
    10. Click "Start"
    11. Test.

  • For Controller 10.2.0 (and earlier):

  • 1. Logon to the Controller application server as a Windows administrator
    2. Right-click on "My Computer" and choose "Manage"
    3. Expand "Services and Applications" and "Services"
    4. Double-click on "IBM Cognos Controller Java Proxy"
    5. Click tab "Log On"
    6. Modify the settings for "Log on as" as appropriate.
    • In other words, choose "This account"
    • Modify user to be a Windows user who is a local administrator on the application server (typically use the same user as the "COM+ user")
    7. Click OK
    8. Click "General" tab.
    9. Click "Stop"
    10. Click "Start"
    11. Test.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21619686