IBM Support

Connect:Direct installation failed with error 1935

Troubleshooting


Problem

Installation failed with error 1935. An error occurred during installation of assembly component.... Event log: Product: Connect Direct for Windows Setup Support -- Error 1935.An error occurred during the installation of assembly component {76C3F0F6-9B9D-35DA-81C6-CA8A88CC93CA}. HRESULT: 0x80070BC9. assembly interface: IAssemblyCacheItem, function: Commit, assembly name: Microsoft.VC90.ATL,type="win32",version="9.0.21022.8",publicKeyToken="1f c8b3b9a1e18e3b",processorArchitecture="x86"

Symptom

rollback after error occured

Cause

missing OS system components

Environment

Windows 2008 R2

Diagnosing The Problem

check whether Microsoft Visual C++ 2xxx Redistributable (x64) and (x86) is installed

Resolving The Problem

Install missing Microsoft Visual C++ 2xxx redistributable

NOTE: very important: vcredist_x86.exe

C:D need the 32bit version

[{"Product":{"code":"SSRRVY","label":"IBM Sterling Connect:Direct for Microsoft Windows"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"4.6","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
24 July 2020

UID

swg21619573