IBM Support

Unable to use to install RaPM

Technote (troubleshooting)


When attempting to install the Tivoli Integrated Portal portion of the IBM Security Role and Policy Modeler, will not execute due to an unsupported browser version.


Attempting to run results in the message "Unable to find supported browser".


The script sets up certain variables, and the install will fail if these are not configured. This typically occurs when Firefox has been upgraded to version 10, as the current script does not know about that version.

Diagnosing the problem

Use the "firefox -version" command to determine the exact version of Firefox that you have installed.

Resolving the problem

To allow Launchpad to work, please edit the <install_root>/launchpad/ command so that it contains the following string in the supportedFirefoxVersion case statement:

*Firefox\ [1-9][0-9].*) return 0;;

The function should then look like this:

case "$*" in
*Firefox\ [1-9].*) return 0;;
*Firefox/[1-9].*) return 0;;
*Firefox\ [1-9][0-9].*) return 0;;

After the changes, should run successfully.

Product Alias/Synonym

enrole tim itim isim rapm

Document information

More support for: IBM Security Identity Manager
Role & Policy Modeler (RaPM)

Software version: 1.1

Operating system(s): AIX, Linux, Solaris

Reference #: 1619200

Modified date: 30 November 2012