** Troubleshooting ** Error "Could not attach to JVM" when using Controller

Technote (troubleshooting)


Problem(Abstract)

User receives an error when using Controller.

Symptom

The exact error message will vary depending on what task the end user is running. However, it will contain the following text:

    Could not attach to JVM


Cause

There are several possible causes for this error:

  • Scenario #1 - CCR_INTEGRATION_SERVER_DEPLOY_HOME system variable not set or is pointing to the incorrect location.
    • Only affects Controller 10.1.1691 and earlier
    • See separate IBM Technote #1611097.
  • Scenario #2 - The Java class path is not set up correctly on the server side. This causes the service "IBM Cognos Controller Java Proxy" to not be able to find a suitable Java Virtual Machine.
    • See separate IBM Technote #1414684.
  • Scenario #3 - Customer has a physically separate (dedicated) consolidation-only server, and the functionality ONLY fails when running consolidations.
    • This is caused by the JAVA environment not being correctly configured on the consolidation server.
    • See separate IBM Technote #1571738.
  • Scenario #4 - (rare) Controller database has been copied/moved to new server environment (e.g. new SQL server) and the database tables are being incorrectly accessed by the wrong SQL user.

Resolving the problem

Scenario #1

If using Controller 10.1.1691 or earlier, check existing/create-new "CCR_INTEGRATION_SERVER_DEPLOY_HOME" system variable.

  • See separate IBM Technote #1611097.

Scenario #2
Ensure that the IBM Java 1.6 is installed on your system. Afterwards, set the system variable "CCR_JAVA_HOME" appropriately, on the application server.
  • See separate IBM Technote #1414684.

Scenario #3
Reconfigure the consolidation server's JAVA environment.
  • See separate IBM Technote #1571738

Scenario #4 (rare)
Ensure that you are connecting to the SQL database using the correct SQL user (e.g. "fastnet" or "sa" as appropriate).
  • If using a non-sa account (e.g. "fastnet") ensure that you have removed orphaned users by running a script similar to the following:
      EXECUTE sp_change_users_login 'Update_One', ' fastnet', ' fastnet'

Related information

1611097 - Could not attach to JVM
1414684 - Error 'Could not attach to JVM' when launchin
1571738 - "Could not attach to JVM" and "Execution of A

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Document information


More support for:

Cognos Controller
Controller

Software version:

10.1.1

Operating system(s):

Windows

Reference #:

1619105

Modified date:

2012-12-17

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