IBM Support

"CM-SYS-5003 ... Connection failed, no login ack received" when attempting to start Cognos service using a SQL Server content store database with Windows Authentication

Troubleshooting


Problem

Administrator launchs 'Cognos Configuration', and clicks the 'start' button. Administrator clicks 'Details' in order to see how the startup is progressing. After a while, an error appears.

Symptom

The text will contain a large amount of information, including the following:

CM-SYS-5003 Content Manager is unable to connect to the content store. Verify that the database connection properties in the configuration tool are correct and that when you test the connection, the test is successful. Cause: Failed Logon:com.jnetdirect.jsql.JSQLException: Connection failed, no login ack received

Cause

The "Log On as" user specified for the Cognos service does not have access to the SQL Server database instance specified within Cognos Configuration.

Environment

'Cognos Configuration' is configured so that its 'Content Manager' is configured to use a SQL database via a connection type 'Microsoft SQL Server database (Windows Authentication)":

Diagnosing The Problem

1. Logon to the application server using the same Windows username that the Cognos service (typically called "IBM Cognos") is using.

2. Right-click on the 'Content Store' entry, and choose 'Test'.


3. Troubleshoot any errors that you see.

Resolving The Problem

Ensure a domain user that has access to the SQL Server database is specified in the "Log On As" property of Cognos service.

Steps:

1. Logon to the Cognos application server as a Windows administrator

2. Launch 'Cognos Connection' and make a note of the Windows service name (inside "IBM Cognos services" section)

  • In the example below, the name is "IBM Cognos".


3. Open the Windows "Services" tool

4. Locate the relevant Windows service (for example 'IBM Cognos')

5. Make a note of the current value of 'Log On As' (for example 'Local System')

6. Right-click on the service, and choose 'Properties'

7. Click tab 'Log On'

8. Modify the value of 'This account' to be a Windows user who has full access to the SQL database (for example 'mydomain\my_user'):


9. Save changes
10. Test.

Related Information

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3;10.2.1;10.2.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21618726