Installation of WebSphere eXtreme Scale Version 7.x fails on Red Hat Enterprise Linux V6 64-bit

Technote (troubleshooting)


Problem(Abstract)

When trying to install WebSphere eXtreme Scale Version 7.x on a x86 64-bit Red Hat Linux operating system, the ISMP installer fails.

Symptom

On a Red Hat Linux operating system, the installer fails with the following message to stdout:

The directory /root/istemp405100614345 does not contain enough space to extract temporary files. Please specify a temporary directory using the -is:tempdir option. Use the -is:help option for more information.


Cause

The ISMP installer requires 32-bit versions of the Linux operating system libraries. Some of these libraries are not installed by default with Red Hat Enterprise Linux V6 64-bit.


Diagnosing the problem

Issue the following command to capture a log from the failed installation:


./install -is:log /root/mylog

---
The generated output file (/root/mylog) should look something like this:

Log file created by ISMP installer
Checking the environment variables specifed in the JVM files to find the JVM...
No JVM can be found using the shell environment variable. Searching JVM will continue with Path Hints specified in the JVM Files...
jvm files not specified. Searching a JVM can not be performed.
Extracting bundled JRE...
checking disk space on the parition /root/istemp5180006144157 for /root/istemp5180006144157/ibm-java-jre-6.0-9.2-linux-x86_64.bin
140242 512 bytes disk blocks required.
184116536 512 bytes disk blocks available on the partition /root/istemp5180006144157
Disk space check on the parition /root/istemp5180006144157 succeeded.
checking disk space on the parition /root/istemp5180006144157 for /root/istemp5180006144157/ibm-java-jre-6.0-9.2-linux-x86_64.bin
Bundled JRE is not binary compatible with host OS/Arch or it is corrupt. Testing bundled JRE failed.


Resolving the problem

Install the following required 32-bit packages by selecting to customize the packages during the RHEL 6 installation or by installing the packages later through the appropriate rpm or yum commands.

Platforms that support both 32-bit and 64-bit applications require both the 32-bit and 64-bit versions of the following packages:

compat-libstdc++-33-3.2.3-69
compat-db-4.6.21-15
libXp-1.0.0-15.1
libXmu-1.0.5-1
libXtst-1.0.99.2-3
pam-1.1.1-4
libXft-2.1.13-4.1
gtk2-2.18.9-4
gtk2-engines-2.18.4-5

Rate this page:

(0 users)Average rating

Document information


More support for:

WebSphere eXtreme Scale
Install

Software version:

7.0, 7.1, 7.1.0.2, 7.1.0.3, 7.1.0.4, 7.1.1, 7.1.1.1

Operating system(s):

Linux

Reference #:

1617870

Modified date:

2012-11-20

Translate my page

Machine Translation

Content navigation